Audio codec options, getting lost,?



Trying to rip bd’s to mp4 and keep the dolby audio intact so my media server sends the audio out “RAW” or bit stream and then receiver deals with the audio.

The video settings do not seem to have any impact. I get great results with either h264 or mpeg4.

AAC or AC3 also over all do not seem to matter.

If I set the audio option to 5.1 I end up with multichannel PCM in the final mp4 and if I set my media server to HDMI LPCM Multichannel out I have multichannel sound at my receiver. Sounds quite good.

If I select any of the Dolby options the final file only has 2 channel audio. Verified with file properties for the audio component.

I tried a couple of bd’s with a hd audio track and a ac3 audio track. Selected the AC3 audio track when making the mp4 and AC3 Dolby.

Still only had 2 channel audio in the final file.

It feels like I’m missing something, some setting.

What do I need to tell DVDFab in terms of audio settings in BD Ripper so that the mp4 will have dolby which I can send out raw and let my receiver decompress it?

Do I need to select a different file type in general and not use mp4?


I have deleted the other two threads that are duplicates of this thread, we may be having server issues so please do not click on the submit button more then one time to avoid duplicating your posts.


I have also deleted your other post on this but with a different title, do not double post for the same issue or question even with a different title, it is still double posting and not within forum rules.

[B]SJ[/B] :cop:


Actually I didn’t double post. The site is acting weird…

Thanks for deleting them.


[QUOTE=jsmiddleton4;2641068]Actually I didn’t double post. The site is acting weird…

Thanks for deleting them.[/QUOTE]

The two was done by website, the other with a different title was not.

In any case the duplications have been dealt with.


Any advice on the issue?


[QUOTE=jsmiddleton4;2641072]Any advice on the issue?[/QUOTE]

I may have over looked it, so I will ask…

Have you tried the ‘Same as source’ setting ?


Yep. But I don’t want same source. Can’t keep the HD Audio on the MK4. Has to be non-HD.

Dolby not getting to final file.


I do not have a problem helping you at all< I was under the impression you had one with me.

However have you tried copying(not converting) to your HDD saving it the way you want then using that resulting output and then converting ?