Audacity problem in Vista cannot record

I use Audacity to record streaming audio to .wav files. I got a new system with Vista a few weeks ago and when i try to use Audacity now, I get the flatline when recording. I have chosen all the options for the record device (Line In, MS Sound mapper, mic) but I still get flatline. I had no problem in XP doing the recording. I checked a couple links from the web, but nothing helped, anyone here have this issue and able to fix it?

Hi there,
Someone posted with a similar problem a couple of weeks ago.
I don’t use Vista at all, so am just relaying advice that Cressida gave, in that the audio controls for Vista have been improved and you will need to change some settings to get Audacity to work properly.

Links that explain how to do it:
http://audacityteam.org/wiki/index…indows_Vista_OS
http://audacityteam.org/wiki/index…_Toolbar_Issues

Hope that helps

Those links don’t work, but I think I know which ones they are. I checked them out, still nothing. I updated my drivers now too, and my recording devices are now BLANK! Says nothing is connected to record…

Hi again, yup, the links were blank :doh:
But I just checked the www.audacityteam.org web site wiki, and there is a page dedicated to the Vista OS, with details on how to set up sources.
Post back if none of that info works for you.

The links don’t work because of the abbreviation on the board :wink: . As I said in the other thread (and I can’t try this myself either :slight_smile: ), it may not be possible to record the line-out signal in Vista (without physically connecting line-out to line-in). Could depend on your hardware and drivers I suppose (or would it be inspired by DRM).

LOL! I was having one of those jet-lag moments of confusion at that point :bigsmile:

None of the ideas worked, but I found one that did. I read a lot about left clicking the open areas in recording devices to find Stereo Mix, but that didn’t work at all. What I did was get an audio cable splitter and split the cable coming in from the speakers into line in and line out. Now I can record using Line In as the device, BUT the problem I found is the recording is done at the volume level. If the volume is adjusted mid stream you can hear it in the recording. As long as you maintain even volume, all sounded fine.

I just had the same problem. I couldn’t get audacity to record. I have a new HP pavilion running vista (all my other machines have been xp or earlier).

I couldn’t get Audacity to recognise an input except the mic, tried everything and then cleaned the registry (over 200 errors on a two week old machine) once I had done this the audio codec appeared in the recording preferences. The select input box on Audacity is still grayed out but the input can be selected under preferences.

My recording works from line in and from the mic array in the PC (selection by the preferences menu under edit). However if the volume is turned up during recording I get feedback - the mic is turned off, I can’t figure where it is coming from. I suspect microsoft don’t understand sound, but with the volume on audacity turned off I get perfect stereo sound recording just like I’m used to under xp.

I suspect the names of the processes were incompatible. My machine has Korean vista and was switched to English (by the shop, they were very helpful). I know windows is somewhat picky about getting the names right.

Hope this helps.
I was very cross but now feel quite relaxed and reasonably happy.

If your sound card set-up does not allow you to record streaming audio with Audacity, try this…

Connect your speaker jack directly to the microphone jack
Set Audacity speaker and microphone levels to about 0.2
Control the volume…therefore the peaks…using the computer volume control

Note 1) On this Dell…whenever anything is plugged into the microphone jack the option window opens to ask if it is a microphone or line-in.
Note 2) The illustrated example shows Audacity 1.3 Beta

I experienced the problem recording the speaker output (Stereo Mix) with Vista 64 and my Gigabyte GA-EP45-UD3P Motherboard. It has the Realtek ALC889A onboard audio. What happened is that the standard Microsoft drivers for your audio have the Stereo Mix disabled (because, of course, we must make sure that you cannot infringe copyright even if that renders your PC inoperable). Nothing you do will get them back unless you load the Realtek drivers for your audio.

I found the drivers for mine at:
http://america.giga-byte.com/FileList/Driver/motherboard_driver_audio_realtek_azalia.exe
Go to the Gigabyte website and put your motherboard number in the search box and then Search For -> Driver.

Install the driver and you should get another speaker icon in the tray for the Realtek HD Audio Manager. Right click then select Audio Devices. In the Recording Tab you should now have CD Audio and Stereo Mix. Enable those.

In Audacity, Edit -> Preferences, Audio I/O Tab, Recording Device dropdown, select Stereo Mix. Play other tracks while recording new one can be checked but make sure that Software Playthrough is unchecked. You will now be able to record the audio output of your PC in Audacity.

IFAIK, this will work for any audio chipset. Just determine your exact soundcard or motherboard model, go to the manufacturer’s website and download the most current AUDIO drivers for your Vista flavor.

[QUOTE=deanimator;2247133]If your sound card set-up does not allow you to record streaming audio with Audacity, try this…

Connect your speaker jack directly to the microphone jack
Set Audacity speaker and microphone levels to about 0.2
Control the volume…therefore the peaks…using the computer volume control

Note 1) On this Dell…whenever anything is plugged into the microphone jack the option window opens to ask if it is a microphone or line-in.
Note 2) The illustrated example shows Audacity 1.3 Beta

[/QUOTE]

Great post ! I happened to have a cable with mini plugs on each end so I could connect my mike jack to the earphone jack and tried thi. Iit worked pretty well. Have to have the computer volume control at the very lowest setting to avoid distortion. The first recording, from Pandora.com, was sort of distorted which may be due to not having a premium account that provides better quality. A second recording from youtube.com/disco provided much better results. I understand that using the mike input can result in reduced quality sound due to computer electronics and is one reason USB mikes are recommended. I see that it is possible to get cables with a USB connection on one end and miniplug or jack on the other end which will let you connect the earphone jack to the USB port. Wonder if this will also work and provide better results, or blow up the damned machine… We will see.

There’s also a $20 bit of software called Total Recorder that installs a ‘virtual sound device’ that allows recording any audio stream in your PC. I’ve been using it for years and it still works well.

I’ve run thru all the comments here, tried the earphone to mike jack successfully, and just tried freecorder.com which works while Audacity does not. You have to put up with another toolbar, but after a half hour of fiddling, find it to work well and some of the toolbar settings are useful. I was going to try a USB port connected to the earphone jack, but freecorder will do just fine for now.

OK, so 4 days later using Freecorder after my previous post I find the program to be better than the first experience. First off, it records multiple MP3’s separately, so you don’t have to start and stop it. However, it does not identify MP3’s by other than time of recording. It also sets the volumn to an optimum level. It can be added as a toolbar to Firefox where a simple click quickly sets it in motion. Now, it does not allow editing like Audacity. It does plunk a small window on your desktop and keeps it on top unless you change the settings. If you want it available on top but out of the way and don’t change keeping it on top, it can be slid to the side or corner of the screen so only a tiny piece shows. You can do other activities as long as the window with the feedstream is not closed. If that window is lost, Freecorder will still save everything up to that moment. I’ve had a periodic problem with Audacity crashing when I stop a recording, which can mean the loss of however long that may have been. Freecorder has not done that, but on my laptop the record window shows an almost flat line, unless I run a jumper cable from the laptop earphone jack to the mike jack. Because that is a problem area I’ve ordered a USB plug adapted to stereo and mike jacks to see what difference it makes. eBay has them for about $8, including postage, so it’s cheap enough to try out. It’ll be a week or so before the part arrives, but I’ll post more after trying it ou.

The USB adapter arrived from China after 13 days. The label on it says 3D Sound and it has mike and earphone jacks for a miniplug. It does not help solve the problem for Audacity and has no effect on Freecorder. It does allow the use of a mike or earphones by way of any USB port, and it will mute the laptops’ built-in mike and normal earphone jack. However none of this changes how Freecorder works, and use of Audacity still requires a jumper connected to either the USB device or laptop mike/earphone ports. In addition when the jumper is used with the USB device, all recordings are distorted and unuseable. In addition Audacity continues to freeze up on occasion. The Freecorder has locked up once before the USB device was received and both programs are more likely to freeze up while in operation if the USB device is installed and removed. In conclusion I will use Freecorder for any recording and Audacity for editing of the results.