Audacity Could not open MP3 encoding library

vbimport

#1

I'm running Audacity 1.3.9 (Unicode) under Windows XP SP3 on a hand-me-down laptop.

I'm trying to use Audacity to export to an MP3 file but keep getting this message:

"Could not open MP3 encoding library!"

I've tried downloading various versions of the lame_enc.dll file and then manually selecting them in Audacity when I attempt the export operation, but to no avail.

I've read numerous messages in the Audacity forums from others who over the years who have run into the same problem, but I'm having trouble understanding much of what has been posted. I'm disabled by chronic health problems that have impaired my cognitive skills and I also suffer from intermittent seizures that impair my memory.

I'd be grateful for some help in troubleshooting this problem.


#2

Here is the way to install and set up Audacity to use Lame…
From the download page you need to install, "[B]Lame v3.98.3 for Audacity on Windows.exe[/B]"

In Audacity-> Edit-> Preferences-> MP3 Library and locate/navigate to, [B] lame_enc.dll[/B] …


#3

First you need this:
http://lame.buanzo.com.ar/Lame_v3.98.3_for_Audacity_on_Windows.exe
Install it.
Then try to export a .mp3 from Audacity.
It should ask for the location . Which should be C:\Program Files\Lamefor Audacity.
If that fails manually locate it this way:
Edit\Preferences\Libraries then select to Locate MP3 library


#4

Hi cholla!

Thanks for jumping in to try and help me out.

Before posting my query I had already followed, over and over, essentially the same steps that you outlined in your post. But I always ended up with that same error message.

Here’s what I did. Maybe I’m missing an important step. Could you review my steps to see if you can see where I’ve gone wrong?

I download four (count them! four!) copies of Lame_v3.98.3_for_Audacity_on_Windows(4).exe) and dutifully installed each one of them, one after the other, in Program Files/Lame For Audacity.

Each time, with a fresh copy of lame_enc.dll, I would retry exporting my project as an MP3. And each time I got the same little “Locate Lame” dialogue box. Inside the little white field labeled “Location of lame_enc.dll:” this is what appeared:

C:\Program Files\Lame For Audacity\lame_enc.dll

But, when I clicked “OK” I got this message:

“Could not open MP3 encoding library!”

I’d be grateful if you (or anyone for that matter) could review the steps I took and point out to me where I made my misstep. This is so danged frustrating to be spending so much time on something that should be so easy to do.


#5

Hi t0nee1!

Thanks for the help!

Could you take a look at my reply to cholla and see if you can see where I’ve gone wrong?


#6

You most likely have the zip download or installed in other location, and didn’t accept the default location, which is (C:\Program Files\Lame For Audacity\lame_enc.dll)…Find where lame_enc.dll actually is, and point/show Audacity where to find it…



#7

I don’t know that I can improve on t0nee1’s post.
my Audacity is set like this & works fine.



#8

Here’s what my “Locate Lame” dialogue box looks like:

Maybe you guys could look at it and see if you can see what’s wrong.

P.S. How do you insert images into messages? The only way I could figure was to attach it… But then it shows up twice.



#9

You need to use the ’ [B]Browse[/B]’ tab and locate where lame_enc.dll actually is located…


#10

That’s exactly what I did.

lame_enc.dll is located in C:\Program Files\Lame for Audacity

Maybe I need to try downloading a different version of Audacity.

Which version do you recommend?


#11

I’m getting nowhere with trying to get Audacity to produce an MP3 file.

Maybe I should just throw in the towel and instead have Audacity create a FLAC file and then use a conversion utility to create an MP3 from the FLAC file.

Can you recommend one that’s easy to use?


#12

[I]One[/I] of the easiest tools to convert flac to mp3 is this…
http://mulder.dummwiedeutsch.de/home/?page=projects#lamexp
Just drag n drop to convert from one format to another format…Or this
http://www.xrecode.com/
There’s many other apps/tools available…Foobar2k, dBpoweramp, MediaMonkey etc etc…


#13

Just checking on a couple of things.
You are setecting the [B]OK[/B] button in the [B]Locate Lame [/B] box ?
What type file are you trying to convert to .mp3 ?
I’m using a little newer version of Audacity but I don’t think that is the problem you are having.


#14

Hi again, guys! I’ve got good news and bad news.

The good news is that I was able to get Audacity to produce an MP3 file.

The bad news is that I had to use a different computer running Win 2K :eek: instead of the laptop running a Toshiba version of Windows XP.

As far as I can tell I’m running identical versions of Audacity and Lame on both computers.

So the problem may originate in an incompatibility between Audacity/Lame and the Toshiba version of XP.

I’ve not been doing too well the last few weeks, so I’ve been working almost exclusively on my hand-me-down laptop while resting in bed. But I seemed to recall having used Audacity on my old (also hand-me-down) PC to produce MP3s.

So this morning I forced myself to drag my sorry you-know-what out of bed and sat down at my desk and fired up the PC, ran Audacity, and it worked without a hitch using the same ,aup file that Audacity on the Toshiba had been choking on for the last couple of days.

So, I don’t think there’s any point in trying to solve the mystery of why Audacity/Lame won’t work on the Toshiba. I’ll just use the other computer for making MP3s from now on.

Thanks for your tenacity in sticking with me in trying to lick this problem. I’m grateful to you both for your continued generosity in sharing your expertise and time with me.


#15

Since you are used to Audacity using the PC might be your best solution.
I use dbPowerAmp version 10 that I’ve had for a long time. I’ve modified it quite a bit & it works well. The newer version has a trial that expires. Version 10 is available on the internet but I’m not to sure about the download sites .
I also use BeSweet with BeLight GUI. It also takes some additional files including Lame_v3.98 to update the old version that comes with it.
Exact Audio Copy can also be set & used to create .mp3’s from .wav so there should be some options for you to be able to do this with your laptop.
Also CDex can do this conversion.


#16

I have just installed several versions of Audacity and several versions of Lame (including the latest/recommended releases) and the only combination that works to export in mp3 format is:

[B]Audacity 1.3.0 Beta[/B]

[B]LAME MP3 Encoder 3.98.4[/B]
http://www.free-codecs.com/Lame_Encoder_download.htm

Every other combination produces the “Could not open mp3 encoding library!” for me. I am running Windows XP +sp3 in April 2011.


#17

@ fleawhale , Have you tried what I’m posting below?

I have Vista & this is what I’m using . It works with .mp3 exports.
1.3.12 (Beta).


Lame v3.98.3 for Audacity on Windows.exe

Windows
1. Go to the LAME download page.
2. Under “For Audacity on Windows”, left-click the link “Lame v3.98.3 for Audacity on Windows.exe” and save the file
anywhere on your computer. Do not right-click the link to the .exe file.
3. Double-click “Lame v3.98.3 for Audacity on Windows.exe” to launch it (you can safely ignore any warnings that the
"publisher could not be verified").
4. Follow the “Setup” instructions to install LAME for Audacity. Do not change the offered destination location of “C:\Program
Files\Lame for Audacity”.
5. The first time you choose “File > Export as MP3”, Audacity will ask for the location of “lame_enc.dll”. Navigate to “C:\Program
Files\Lame for Audacity”, select “lame_enc.dll”, then click “Open” and “OK”. In Audacity Beta, choose “File > Export”, select
"MP3 Files" in “Save as type”, then export should proceed immediately.
6. If you prefer the Zip option for the LAME download, save the zip file to anywhere on your computer, extract “lame_enc.dll” to
any location, then show Audacity where to find it as in Step 5 above.
7. In case of difficulty, please view our more detailed instructionson the Audacity Wiki.