Attempting install of new optical drive into DVDR77

vbimport

#1

I have a DVDR77 that is failing with DISK WARNINGS and DISK FAILUREs. The unit is out of warranty, so I decided to try fixing it myself. I opened it up, and found that it was fairly easy to remove the optical drive.

The optical drive looks like a standard PC style drive. It didn’t have a label saying what it was, but
there were a few mysterious code numbers on it, so I tried Googling them. One of them lead me to a BenQ drive. I then discovered that BenQ and Philips have a partnership, so it makes sense that this would look like a BenQ drive.

For $50, I bought a BenQ DW1620 which is a DVD+/-RW DL drive. I removed the front bezel and installed the drive into the DVDR77 expecting that it probably wouldn’t work at all. Much to my surprise, it kind of works…

When I open the tray, the screen reads “Tray Open”. When I put in a disc and close the tray, the display reads “Closing” and remains there forever as if it is waiting for a response from the drive.
After a power cycle, the unit reads the disc and I am able to proceed with playing it. If instead, I close the tray by pushing on the drawer, the recorder doesn’t notice a thing. Then if I push the close button the display says “Closing” briefly and then it reads the disc.

From here, I can play discs just fine. I have even recorded sucessfully to discs, but it is there that I encounter more problems with the DVDR77 not knowing the drive is done.

I had success recording to a DVD+RW disc that I had previously recorded to. I overwrote the last title and it recorded fine. When I pressed STOP to stop recording, it did the menu update and I could hear the drive accessing, then it just froze there. Again, the drive was done, but the DVDR77 didn’t know the drive was done. After a power cycle, I saw that the disc had been properly updated.

I tried adding a chapter to an existing title on the disc. Again, the unit reported UPDATING and just froze there after the drive was done. After I power cycle, I could see that the disc was updated correctly.

So close, and yet so far.

I might trying flashing the drive with Philips firmware to see if perhaps Philips firmware behaves differently.

Anybody else ever try this? Any ideas?

Thanks,
Chuck