ATMOS Audio Drop Outs - Details thread


#141

Except, according to Balthazar2k4, DeUHD folder and a MKVToolNIX remux works on the discs he tested.
Also, in past I found that some apps would create a MKV that was practically unusable. Remux with MKVToolNIX solved the issue, this was 1080p sources


#142

To many remuxes


#143

perhaps a red herring but using mkvtosnix i dont ever recall seeing it report audio sync errors and dropping frames. makemkv often reports this

wonder if that combined with seamless branching might play a role

in any case above seems to implicate lav. folder rips also have this issue through jriver media center (lav) based on @jmone1’s experience. given hendrick’s reponse, he does not think he can do anything about it


#144

See my comments above. I removed MakeMKV from the chain and still got exactly the same audio drops on the Incredibles 2. My approach was to rip the full disk via AnyDVDHd and use Mkvtosnix to build the MKV file.

Also @Sevenfeet, looks like there is a difference on behavior between Windows and Oppo when playing with the original folder structure. Using MPC-HC + Lav I still got the same audio drops, even when opening the 800.mpls file directly.


#145

Removed MakeMKV and introduced DVDFab
Rip to folder with AnyDVD, if you must, and then extract with MKVToolNIX to mkv


#146

I did some more testing. Same results regardless of the Ripper (makeMKV, DeUHD, Anydvd). Drop seems to be at some of the Seemless branching points (eg 3:16). Had a look using ffmpeg (as this is the basis of LAV) to remux and it just the main Video & Atmos track. Same Drop out at 3:16 and interstly it thew a bunch of these errors:

3586523. This may result in incorrect timestamps in the output file.
[matroska @ 000002434ebee200] Non-monotonous DTS in output stream 0:1; previous: 3586523, current: 3586515; changing to 3586523. This may result in incorrect timestamps in the output file.

#147

That’s exactly what I did. Ripped to folder with AnyDvdHd. Then, I played with the results in three different ways:

  1. Played it straight from there, by opening the mpls file with MPC-HC. This step eliminates any mixing issues with MKV ir M2ts.

  2. Used Mkvtoolnix to create one MKV using the rip from step #1 above

  3. Used DVDFab to create a M2ts using the rip from #1 above as well. This is to answer the question if MKV was the problem.

In all cases I got the same audio drop. I hope this is clear now.


#148

Interesting @jmone1. Do you know if Exoplayer 2 uses Ffmpeg? Because I can’t reproduce it using Plex on ShieldTv, which is calling Exoplayer 2.


#149

I don’t sorry - I also just tried demuxing with madshi’s eac3to (then remuxing to MKV) - same issue… and then again, eac3to uses libav/ffmpeg as well.


#150

someone at the Lav Doom9 forum reported that the drops stopped after reverting Lav to version 0.71, which is the version before the Atmos fixes for Pirates of the Caribbean and other titles. I haven’t checked it myself yet, but this could mean that the original fix messed up something else.

https://forum.doom9.org/showthread.php?p=1863949#post1863949


#151

Hendrik has a new build of lav and says he may have possibly fixed it but will need someone to try lav 0.73.1-1

since i am at the moment in the land down under i won’t have a chance till i am back home later this week.

hopefully someone in this thread can test it


#152

It’s great Hendrik is looking at this but 73.1.1 did not fix it. I’ve posted some more at JRiver.

Welcome to Oz by the way. Warm enough for you?


#153

Just tested as well. Same issue as before.


#154

day was beautiful! considering how cold it is back home in the North East US this was near perfect temp with a cool breeze

did the usual first time tourist stuff of course…


#155

I’m away so can not test, but looks like it is fixed in the latest LAV. Check out the JRiver thread for details. https://yabb.jriver.com/interact/index.php/topic,114628.msg825722.html#msg825722


#156

FYI - cross post from the JRiver Thread:

Tested the following historic probs with hard/soft drops and they all played fine with the latest LAV Nightly (all folder rips).

  • “Incredibles 2” - Soft Drop : eg drops at 3:16 at the seamless branching point where it goes to the Incredibles 2 spinning logo
  • “Pirates of the Caribbean - Dead Men Tell No Tales” - Hard Drop : eg drops out a couple of times between 17:45 and 19:00 minutes into the movie
  • “Guardians of the Galaxy Vol II” - Hard Drop : eg drops out at 1:09:24 where TaserFace gets killed is one example.
  • “Maze Runner: The Death Cure” - Hard Drop : eg Right at the beginning of the Main Title when the 20th Century clip is running

Thanks Hendrik - looks good to me.


#157

Confirmed the fix here as well. Thanks for pushing it with Hendrik!


#158

Guess I am going to have to fire up the 'ol HTPC and give it a shot. Thanks to Hendrik and @jmone1 for working the problem.


#159

@jmone1, how did you apply the nightly release? did you install LAV or use a tool to expand the installer to files and just copy the DLLs and such into the appropriate JRiver MC plugins folder?

and if so, any post steps from there?


#160

The “cleanest” way is

  • Download latestLAV Nightly
  • use innounp to unpack the the EXE (eg innounp -x lavfiltersXYZ.exe)
  • copy the contents of the x64 (or x32) depending on your MC Installed Version to the plugin directory eg C:\Users[username]\AppData\Roaming\J River\Media Center 25\Plugins\lav64

Good to go. Slack way (that I’ve used many times) is to install LAV and copy the files from the install to the plug in directory