ATMOS Audio Drop Outs - Details thread


#121

I’m the one who reported it over at the MakeMKV forum.

I had a feeling that this is an old issue since I’d seen it before on a few Atmos titles but not to the degree of Incredibles 2. With other titles, you’d get a momentary drop out and then everything would be fine. Not only did it happen a lot in Incredibles 2 but there were spots where the sound wouldn’t come back at all.

I use an Oppo 203 exclusively for playing my Atmos titles. Oppo tech support says that the same sound code is used for all inputs regardless of where it came from. Everything is ripped with MakeMKV, currently on version 1.14.1. For Incredibles 2, there are a number of places where drop out can (and usually do occur).

Chapter 1: 1:40 (Car nearly dropped on Tony Rydinger)
Chapter 2: 4:59 (Underminer leaves the fight with Mr. Incredible, “Bye-Bye!!!”)
Chapter 6: 16:40 (Winston Deaver meets the Supers, “I love Supers!”)

Chapter 14: 46:35 (Elasticgirl boards the helicopter, “Stay in your seat ma’am!”
Chapter 14: 47:00 (Elasticgirl kicks Ambassador’s security out of the helicopter and executes a loop de loop)

There are other places but Chapter 14 is easily the most reproducible of the bunch. The helicopter doing the loop de loop in Chapter 14 is so bad that the audio drops out for a few seconds and sometimes doesn’t come back at all. My Marantz 7703 processor’s front panel lights just drop entirely when the audio problems occur here where in other places on the movie, they may blink momentarily.

I also have the movie completely backed up via MakeMKV to a file structure that I can play with my Oppo 203 on a Windows server via SMB. When I do it that way, it plays perfectly. If I use an MKV file, then I have the problems.


#122

Just tested some of your timestamps on my oppo 205 same dropouts! , also the new The Lion King UHD is going to be a dozzy, haven’t tested it yet but the odds are not in our favor:

Here are the specs of the Atmos track.

Audio #1
ID : 2
Format : TrueHD
Format profile : TrueHD+Atmos / TrueHD
Codec ID : A_TRUEHD
Duration : 1 h 28 min
Bit rate mode : Variable
Bit rate : 8 910 kb/s
Maximum bit rate : 11.8 Mb/s
Channel(s) : 8 channels
Channel positions : Front: L C R, Side: L R, Back: L R, LFE
Sampling rate : 48.0 kHz
Frame rate : 1 200.000 FPS (40 SPF)
Compression mode : Lossless
Stream size : 5.50 GiB (11%)
Title : Dolby TrueHD/Atmos Audio / 7.1 / 48 kHz / 8910 kbps / 24-bit
Language : English
Default : Yes
Forced : No
Number of dynamic objects : 13
Bed channel count : 1 channel
Bed channel configuration : LFE


#123

Yeah, I have a Oppo 205 as well that used to be in my home theater before I moved it to the two channel audio room. It had some of the same issues on earlier Atmos titles.

I’ll pick up the Lion King UHD when it drops on Tuesday. And we’ll see how bad he problem is there.


#124

@jmone1, have you heard any updates on this from Hendrik?


#125

Nope - Not yet. He seems to be quiet at present which either means he is heads down on something for JRiver or is enjoying the Holidays (though he is around).


#126

I watched yesterday The Predator and Incredibles 2. The Predator had 3 Atmos dropouts, I wonder if it’s due to Fox’s Aquisition by Disney since I had not experienced dropouts on none-disney titles.

With Incredibles 2…it was nearly unwatchable, I lost count when I was with dropout number 25!! It really gets irritating when you’ve paid so much for that experience…I don’t remember so many dropouts since Cars 3.


#127

What is everyone using for playback where this occurs?

For me, it’s JRiver / nVidia 1080Ti with audio over HDMI


#128

Oppo UDP-203 with SMB to Marantz SR7011 over HDMI


#129

Could you post the timestamps for The Predator please?


#130

for me, also JRiver / NVIDIA GTX 1080 Ti and Oppo UDP-205 with SMB to Marantz AV7705


#131

I don’t remember exactly because it was only 3 dropouts but I do remember there was one at the begining when the big ship flies and uses the overhead channels. I’ll check it out


#132

have you only tried an mkv?

wondering if the raw m2ts also has this issue directly played back on the oppo.

@jmone1 has at least confirmed m2ts has the issue with jriver.


#133

Yup - as posted on the JRiver forum, I rip to folder and found:

  • The 3:16 Drop out Only happens when Bitstreaming and happens in both Title (uses LAV Splitter) and Menu mode (uses Libbluray). Note: Both modes use LAV Audio Renderer.
  • There is No 3:16 Drop out in either Title or Menu mode when Decoding.
  • There is No 3:16 Drop out when using a XBoxOne S to the same Yami AVR
  • Drop outs occurred with both a Yami and Pio AVR.

Given the feedback from others with the issue, the commonality seems to be LAV Audio Renderer (not the Splitter or Decoder). It could also be the HDMI Audio Driver. Seems most of us are nvidia, any AMD/Intel users able to confirm if they have the drop out? (I can test on one of my Intel NUCs)… Anyway, given Hendrik rewrote this no long ago I think we just need to wait to see what he says.


#134

well his reply over at JRiver is a bit discouraging, unless i missed the sarcasm in his response

beyond Incredibles 2 and The Predator, any other movies have this issue?


#135

Run into an interesting correlation with titles experiencing audio dropouts. I recently decided to convert my 4K HDR discs to 1080p SDR as an alternative copy for my media server. I am processing my discs using RipBot264. While running in batch mode I am finding discs being rejected by RipBot as having no audio track (despite the fact that they do). What’s interesting is that the discs being flagged as rejected are ones identified as having dropouts. Thus far I have Baywatch, Cars 3, and Coco as being rejected, but I only recently started this endeavor so I am confident I will find more. Is this a sign of a mastering issue?

UPDATE: So I decided to try a different approach. I did a complete folder rip with DeUHD and then process the files with MKVtoolnix to create a resulting MKV. RipBot did not throw up a flag and encoded the file. So, there must be some issue with MakeMKV causing this. I am going to try and process Pirates which is a notorious offender with this method and see what happens.

UPDATE: Pirates didn’t flag it. So the only correlation I can find so far is that it has something to do with seamless branching titles. I will continue to investigate.


#136

On the discs with issues
have you tried to create a full folder structure with MakeMKV and then extract the movie with MKVToolNix


#137

just out of curiosity, has anyone done a diff comparing the resulting folder rip of makemkv to deuhd? i think we did a long time ago with at least resulting mkv files, but how about the folder rip (excluding the files that each tool creates)?


#138

I haven’t tried from a MakeMKV folder dump yet. I wanted to completely eliminate MakeMKV from the process to see what the result would be. So far, I have processed the three problematic discs using the DeUHD folder and MKVtoolnix trick and it has worked. I’ll give MakeMKV a shot on my next problematic disc.


#139

I tested the following configs last night:

  1. Folder rip with AnyDvdHd
  2. Remux to a single M2ts with DVDFab
  3. Remux to mkv with mkvtoolnix

In all cases I got the same audio drop at the same exact spot when playing with MPC-HC and lav. The same mkv plays with no audio drop via Shield. So I don’t see any issue with Makemkv. The problem seems to be with LAV or another piece of the pipeline used to play it in Windows.


#140

Ripping the entire folder and playing that way will work correctly with problematic Dolby Atmos titles. This has been my workaround to solve the MKV issue with playback on my Oppo 203. Oppo tech support says that they think the issue is how the file is handling seamless branching. The same audio codecs are used regardless of where the source is…disc, USB, network, it’s all the same to the Oppo.

Given that many of these utilities are using the same open source libraries, I wouldn’t be surprised if there was a common piece of code that is causing the problem between MakeMKV, mkvtoolnix and others.