ATMOS Audio Drop Outs - Details thread


#41

Same here. Played back via JRiver MC 23 (64bit)

I just recently purchased a Vero 4K device to play around. OSMC should have 3D MVC support shortly (or so we are promised). After upgrading the house to a wireless mesh network and tri-band 5Ghz, I can finally stream 1080p content with no stutter.

All my equip in the home theater room however is hardwired into GigE.

What are you guys using for remote streaming, e.g. when traveling?

I travel quite a lot for my job. Typically use Plex.


#42

No probs pulling from MC when remote using either

  • MC Client on a PC
  • MC Remote (like EOS for Andriod, or JRemote)

That said I’m Bandwidth constrained at about 1.5mbs upload from home so I have to pic a “medium” quality profile. Looking forward to when we get the option to upgrade to a 100/40 service.


#43

I use Plex or Emby. Either works fine for me.


#44

It’s funny, I have a JRiver MC license and have never really used the program for anything beyond music. I suppose if I ever go back to an HTPC I’ll have to take a look at it.


#45

what hardware are you using if not an HTPC?


#46

I use an Nvidia Shield and AppleTV 4K.


#47

Having this issue in Kodi, running the latest stable version. Pirates of the Caribbean dead men tell no tales has the same audio dropouts in the same places every time. So I decided to try a different player, tried the movie with Splash player and it bitstreamed flawlessly. Hope Kodi devs find a solution soon. Glad i’m not going crazy lol could not figure out why this was happening but I have to agree that some players inability to handle high bitrates are the cause.


#48

Good to know it plays fine with Splash. Wish I could find something for my ShieldTV that would play it back without the dropouts.

EDIT: I have never used Splash, does it passthrough HDR?


#49

Is this the Splash player you’re talking about?

https://mirillis.com/en/products/splash-free-hd-video-player.html

Never heard of it before…

Interesting if it plays the audio without dropouts. With Kodi - if this player supported it - you could have a rule to spin up Splash for specific titles where audio is an issue.

Edit: looks like no MVC 3D or HDR support from what I can find.

There’s never any perfect player that does it all!


#50

Yea that’s the one, it’s main selling feature I think is the ability to manipulate the framerate, sharpness and color of videos on the fly. Yeah Kodi was “doing it all” for me up until this point lol…


#51

I have raised the issue over at ExoPlayer (Google) on GitHub and created a service ticket. I stole a clip someone created over at Kodi that demonstrates the problem, but I am not sure it is a good clip. Please feel free to chime in over there if you use an Android based playback device such as the Nvidia Shield.

I think I need to find a better test clip and I need to get an ADB debug report off my Shield… good times.


#52

Has anyone come across updates for this issue yet?
Thanks
Nathan


#53

Unfortunately, no.


#54

Thanks - The good news is that it appears to be just these two titles (GOTG II, and POTC DMTNT)


#55

That is true thus far. It strikes me as odd that both of those titles were given such high bitrate TrueHD tracks while subsequent Disney films have not.


#56

These were the very first two UHD BD from Disney/Buena Vista so… it could be poor mastering.


#57

Anyone else had drop outs with “Maze Runner: The Death Cure” (another Disney Title)? I’m going to re-rip to be sure but it was a mess with a bunch of drops outs when bitstreaming ATMOS but seems fine with decoding using the TrueHD stream.

Edit - MediaInfo reports it has a Max Bitrate of 12.1 Mb/s


#58

Disney movies consistently give me some drop and stutter when playing the MKVs Atmos bitstream from my Oppo 203. If I change the audio output to PCM then it’s fine.

Happens with Coco, SWTLJ, and Thor last night had a couple. I’ve played a bunch of other UHD MKVs the same way and had no issues.

If I play the movie as a folder structure full rip, then the audio off the Disney discs is fine as well.


#59

I should also add I tried the same Coco MKV on an attached drive to the Oppo. It stuttered as bad. It’s nothing to do with my network setup.

I may try the new Dune 4k Pro. I’m really curious to see if the same file stutters off another player that can bitstream.

If I play the same Coco file on my Apple TV via Infuse through Plex with the 7.1 PCM output, then its 100% stable. No stutter.


#60

Interesting. I have not played back my rip, but I do see it has the dreaded 12Mb/s bitrate. What’s more interesting to me is that this is the first title from 20th Century Fox in the US with this high of a bitrate. I am guessing these dropouts are repeatable. Do you have any timestamps so I can verify?