''ATAPI DVD DUAL 8X4X12 USB DEVICE'' HHHHHelp

hello…wats happenin…wat my problem is, is i got this dvd re-writer an :

‘‘ATAPI DVD DUAL 8X4X12 USB DEVICE’’…its worked fine for the past say year but lately its been messin up, it wont burn a single thing ne more and cumes up with the followin error message…’‘write error…burn process failed at 8x’’, ive tried help pages and allsorts and it jus says use a different brand ov disc, ive tried multiple brands and i keeps gettin the same thing, so i duno if its broke…if a driver needs updating(cos sumeone told me it could be that) but i aint sure where 2 get a driver from…or ne thing it could be, so i was told 2 try this site cos ppl knows how 2 help…if so let me know thanx

Welcome to cdfreaks. :slight_smile:

To be able help you at all we need more information than provided sofar.
Use Nero InfoTool to find out what firmware your drive uses and other useful details.

Detailed information about your compu, burner and media used would also help.

the firmware for my drive is - ATC1…

Thanks… :slight_smile:

Check the specification more in detail. Does it look like drive in this review?

Also, I suggest you to google by yourself and try to find more detailed information about your drive/enclosure.

Keep us posted.

here is an attatchment ov my nero tool thingy majig