ASUSTeK BW-12B1LT BD-Writer

vbimport

#1

Anyone with this burner?
I’m quite satisfied, but I’m wondering if there is a way to know if this product is really a Lite-On iHBS112 clone (as it seems) or not, and if a crossflash (when firmware updates will be available) will help to improve its performances…


#2

I have the Burner need a firmware dump for it accidently flashed firmware from another drive onto it.
need firmware for
Asus BW-12B1LT-17 made in China in january 2011.
Hope you can get back to me really want to fix my drive its manufacturers warranty has run out.
Also i cannot get the firmware anyway not even Asus has it.


#3

I ran across your thread at that other forum. Talk about getting sidetracked :eek::rolleyes::bigsmile:
You mentioned there that the drive got bricked while you were using the EEPROM utility. Is this the case? Important to know. As your drive is a first-gen mediatek, you may be able to flash this to a iHBS112/212 if you did not completely screw up the EEPROM. Exactly when did this thing start blinking?


#4

It started Blinking when i backed up the eeprom utility i was trying to crossflash my IHAS324 drive and instead when you open the eeprom utility it selected my D drive my Asus BW-12B1LT-17 i stupidly however without looking pressed crossflash and from then on it was blinking i also tried to back up its own firmware with the firmware utility it backed it up i flashed it back to the Asus and it was still blinking.

If i open the firmware up in mediaspeedcodeedit it shows nothing theres no disc type or anything its completely blank which explains why it does nothing.

Was asked on another thread if i even emailed Asus support yes i have twice once i got a crap answer of oh theres no firmware update when i original just want the firmware my drive had not an update.

The second time i never got an answer.

In the eeprom Utility it said the eeprom was fine when i ran a checksum check on it.


#5

Are you quite sure that you didn’t accidentally flash the wrong firmware to the drive with flash utility or flash the wrong EEprom to the drive with EEprom utility before you performed crossflash? Did you use “convert drive” in the crossflash tab? You must understand, the firmware data and EEprom data are two entirely separate things. If you simply tried to “convert drive” with the EEprom utility on a drive with matching EEprom and firmwares, it would normally do nothing. It looks for a mismatch between firmware and EEprom and corrects it if it exists.
Perhaps one of our members knows if EEprom utility convert drive is compatible with a first generation ASUS writer? If it is not, and it screwed up the EEprom data too much, the drive is dead. It is possibly too late, but please also backup the eeprom data?


#6

I clicked convert drive and it said at the end it couldnt do it.

But after that the light on the front of the drive was flashing.

I backed up my drives eeprom and firmware after that while the drives light was flashing.

Then i thaught maybe if i try flash it to another firmware with the firmware utility then flash it back to my firmware it might work again it didnt.

Then i thaught the firmware i got off the drive was prob corrupt and have been looking here and at asus and no one has the firmware.

All i need is someone with the same drive to dumo there eeprom and firmware.


#7

[QUOTE=sean12345;2637532]
All i need is someone with the same drive to dumo there eeprom and firmware.[/QUOTE]

Toasted!
Buy another one.


#8

[QUOTE=sean12345;2637532]I clicked convert drive and it said at the end it couldnt do it.
[/QUOTE]

Try doing it either:

  • in a different computer, or
  • with the drive connected on a different SATA controller, or
  • via a suitable SATA to USB adapter (one which supports ODDs).

The last suggestion helped me several times in the past when from unexplained reasons the EEPROM Utility’s Convert Drive function refused to work with the drive connected internally as usual …

[QUOTE=sean12345;2637532]All i need is someone with the same drive to dump there eeprom and firmware.[/QUOTE]

Don’t mess with the EEPROM! Each EEPROM is unique. Never ever flash another drive’s EEPROM to yours, unless it is a matter of last resort and you’ve got nothing else to lose.


#9

[B]sean12345[/B]:
If you still need the firmware image, I can try to extract it from my BW-12B1LT with a tool (maybe the “Flash Utility for LiteOn based Optical Drives v6.0.1”?).


#10

Here is the original 1.02 firmware:
http://www.2shared.com/file/Gdi7EPFx/102.html


#11

[QUOTE=fastleo63;2641265]Here is the original 1.02 firmware:
http://www.2shared.com/file/Gdi7EPFx/102.html[/QUOTE]

The firmware dump provided is invalid. Your drive might be one of those 2nd generation drives manufactured after July 2011. The Firmware Utility cannot properly dump the firmware of these drives. It only works properly with 1st generation drives (manufactured before July 2011).


#12

Seems I cannot help you, [B]sean12345[/B].
Sorry…


#13

fastleo63, just curious, what’s the date of your firmware?


#14

When I’m at home, this evening, I will look at manufacturing/firmware date.

I know for sure that there are units that were shipped with 1.03 firmware (mine is 1.02), but in ASUSTeK support site there’s no mention of any kind of updates… :frowning:

[B]A little question[/B]: what kind of tool can I use to dump/view firmware contents, and how to compare it to other firmwares, to determine the exact, real make/model of this rebadge?


#15

The most correct way to check whether your Drive is 1st generation or 2nd generation is bus encryption supporting. 1st generation doesn’t and 2nd generation does.


#16

So, if my burner is 2nd gen, I cannot dump my firmware, so i cannot find what the “source” model from which my BW-12B1LT was rebadged?
Is this correct?


#17

[QUOTE=fastleo63;2653694]So, if my burner is 2nd gen, I cannot dump my firmware, so i cannot find what the “source” model from which my BW-12B1LT was rebadged?
Is this correct?[/QUOTE]

If your burner is 2nd gen, then you can’t correctly dump its firmware using the current Firmware Utility or any other publicly available tool (the FU will appear to work OK, it will produce an output file of the correct size but unfortunately the content of the file is just garbage if you look at it with a HEX Editor).

As for the ‘source’ model, the BW-12B1LT is basically a LiteOn iHBS212 rebadge … you don’t need to dump the firmware for that …

The date of the firmware can be seen using software such as Disc Info, DVD Info, Nero Info Tool, Opti Drive Control, LtnFlash, etc …

The manufacturing date of the drive should be on the drive’s label.


#18

[QUOTE=fastleo63;2653694]So, if my burner is 2nd gen, I cannot dump my firmware?[/QUOTE]

Unfortunately Flash Utility v6.0.1 also cannot properly dump firmware from 1st generation Asus BW-12B1LT.


#19

ASUSTeK support for this burner is lacking (no firmware updates available), so it seems that the only way to keep it up-to-date is a crossflash.
What firmware can be flashed onto this BW-12B1LT? The one coming from the LiteOn iHBS212 or the Plextor PX-LB950SA one?
But seems to be a very “risky business”, I don’t want to toast my burner…


#20

My burner specs.
Taken from Opti Drive Control:

And from LtnFlash: