Asus E616P3 Firmware 1.06 having problems updating!

vbimport

#1

Hi guys,
I just bought a Asus DVD-E616P3 (newegg) drive to replace my E616P2. It came with v1.05 firmware. I notice ASUS has newer firmware 1.06 out available for download.

DOWNLOAD 1.06 firmware from ASUS

When I try it, I get “drive name does not match!” error. I read some other threads of people having similar problems with older E616 original drive. They used something called MtkFlash to bypass ASUS crappy flasher. But apparently the firmware must be in .BIN format first, to use this tool. And I do not know how to extract the BIN file from the packed EXE that ASUS gives. Maybe someone with more knowledge can do it?

Can anyone else who has this drive confirm they have the same problem? Or is there some solution? I would like to use the latest firmware.

Thanks :wink:


#2

nobody?


#3

I had the identical situation; I requested and received assistance here:

http://forum.rpc1.org/viewtopic.php?t=33041


#4

beautiful, exactly what I needed, thanks! :iagree:


#5

I guess I must be missing something. I downloaded their beta 1.06 firmware update and got the same unrecognized drive error I get from Asus’ updater. I’ve been having a lot of troubles reading DVDs with my E616P3 drive, to the point of it causing a lot of system hangs. It also likes to downgrade to PIO only for the drive (have to reinstall my secondary IDE to correct). Any help would be appreciated.


#6

I too have had many problems reading dual layer DVD’s, with both of the P3’s that I have tried. I have another on the way and will test it.

If your drive is an OEM, the flash program will not let you upgrade the firmware. The work around is in the link above, where you can switch the drive to retial firmware.


#7

Actually, the P3 workaround link (have to email to get it) will install a firmware based on 1.06, you cannot in turn flash it as though it were a retail drive. It solved numerous issues I was having, thank you again Dangerous Bros!