Asus e-616 very slow ripping problem

Hi

A friend of mine has a dvd-rom Asus e-616 and at the moment he is struggling with a problem with it. The damn thing cant read any dvd above 2x with any soft. (It worked fine before)

I tried with him almost every thing to solve the problem without any success.

His system:
AMD Athlon XP 2200+
Win xp pro
Maiboard : ECL k7s5a
Asus e-616
Sony dru-500a
2 Hdd
512 dimm

Actual configuration:
hdd 1 - Primary Master (detected as UDMA 5 on bios)
hdd 2 - Primary Slave (detected as UDMA 5 on bios)

sony dru-500a - Secundary master (Detected as ATA 33/UDMA 2)
asus e-616 - Secundary Slave (Detected as ATA 100/PIO 4)

We tried everything:
*upgrading firmware of asus from 2.1 to 2.2 and viceversa.
*uningstalling PCI IDE Controllers.
*Installing Adaptec Aspi Drivers (we uninstalled them with killaspi)
*disabling Sony dru-500a
*installing new pci ide controllers from MSI
*hdd1 on master and asus in slave on Primary IDE and hdd2 on master and sony in slave on Secondary IDE.

Nothing worked!! the damn thing still runs on 2x while ripping a dvd.

What do you think is the problem?

PS: We tried to change the Transfer type from PIO to DMA on control panel, but it restores itself to PIO after Restart.

I am not an expert but i have more than 13 years of experience installing computers and i cant see what´s wrong with the dvd driver.

I dont think it´s damaged… weird!

-Richard

I´m still open to ideas…

This has to be some kind of software issue…

-Richard