ASUS DVD e616

vbimport

#1

Had some real adventures trying to flash the firmware on this tonight. I am going to do a clean install of Windows soon so I was getting all the latest BIOSes and firmwares for my comp. So I look at the firware using NeroInfoTool, and it says I have revision Z.0? Well Asus's website says there are no updates for this drive, but their ftp site (ftp.asus.com) says different. Has a windows flash tool and afs (Asus file system) file with firmware for Asus DVD E616 2.0. Seeing Z.0 and 2.0 next to eachother made me think they were the same. Anyway the flasher doesn't work. Says the firmware is not supported by this drive. So I went surfing and found an mtkflash version of the 2.0 firmware. (drive uses mediatek chipset MT1329/1326) flashed ok, and booted into windows. NeroInfoTool said I now had firmware I.0???? So I decided to reflash the other firmware, since z is after I. Renamed back00.bin and back01.bin into bide00.bin and bide01.bin and rebooted. it flashed the first half and then froze. I reset, and it detected nothing on the second channel (has e616 and Lite-On 48125w (actual 48x) on it) Went into mtkflash and tried again. Still froze. So eventually I turned it off. Set it to slave on secondary IDE. still not detected by BIOS, but mtkflash sees it. I leave it on. it reads the first half quick, seems to freeze reading the second half but i leave it and 10 minutes later it has worked. Writes the second half quick, and takes another 10 minutes on writing the second half. But it worked and all is good, although I still have z.0.

So how is this supposed to work. Is I later than Z? Anyone else have this problem? If I flash it to I.0 will the Asus flash tool work?
Help!


#2

I successfully used the version 2.0 flash from asus but it appeared to actually be the Z.0 version. I think Z.0 is the latest version…