ASUS CRW-5232A(52X/32X/52X CD-ReWriter ( doesn't read anymore )

hello ,

I am having some major problems with my CDRW ( Asus Quietrack ASUS CRW-5232A (52X/32X/52X CD-ReWriter52x32x52x )

a few weeks ago I was trying to read some work stuff from a personal CD ( Sony Blank one ) yet it kept on making very small noises and hardly showed the Title of the cd and when I got into the cd , copying a 1 kb file would take like 5 minutes and fails at the end .

so I thought this was a lens cleaning issue ,so I did clean it but its the same thing .

The funny thing is , if I put in a blank cd , it burns it correctly and in its full speed as well .

but it hardly read it afterwards ( the cd is not faulty , tried it on other systems )
Tried all the CDs I’ve got ( and they are alot :doh: )

Just with there was something I could do …

It’s an internal ONE , my system specs if they could help :

AMD Athlon 64 3000+
2x512 Kingston ValueRam
Gigabyte K8NSPRO Mobo ( Nforce2 250 )
XFX Geforce 6600 128DDR AGP8X
2x80 ATA Segate Barracuda 7200.7 Harddisks
Windows XP Pro Sp2
Nero 6.5