Asus CRW 5224 flash problem

Hi all,

I’m a (not so proud anymore) owner of an ASUS CRW 5224 drive. I’ve tried to flash the firmware from v1.0 to v1.1, with the following results:

  • under WinXP (P4, i845PE, unit was sec. master, sec. slave was Asus E616 DVD)-> the ‘incorrect user buffer’ error
  • under Win98SE (Athlon, Via KT133A, unit was sec. master, no sec. slave) ->‘Flash command (W) has problems’ error :frowning:

Now the issues that bug me are these:

  • is the original firmware still intact after 5 unsuccesfull atempts ?
  • how can I do the flashing to 1.1 ?

Any input would be very apreciated :slight_smile:

PS. I’ve already tried booting in Safe mode both in XP and 98 … still no result.

I have the 1.10 firmware in binary format thanks to some kind person :). You could try using mtkflash in DOS (backup your current firmware first and send it to me please) then send me an email with your backup and then I’ll send you 1.10, or just email me and ask for it, but please do backup first.

What benefits, if any, are there from upgrading the firmware of this drive?

Thank you, Dave, for offering to help. (Until your post I wasn’t even sure that mtkflash supported this drive :slight_smile: ). Sorry about the original firmware, but I read your post after I did the deed…

Fortunately, I’ve managed to do the flash myself, on my old i440BX system under Win2k (I guess that was because on that system the IDE drivers were those installed by Windows, and not 3rd party).

I hope that helps others that might have the same problem, and at the same time it doesn’t seem right to me to only work this way (Asus, do you hear ? :confused: )

philamber, word is that this firmware version makes the drive less ‘picky’ about media, which translates in faster writing speeds (I am currrently writing on 40x-rated Traxdata at 52x without any problems). Besides, I had serious issues with UDF-formatted CD-RWs that are now gone…

Marius

I get the user buffer error on this drive too, I dont want to move it all around… Can I get the .bin of 1.1 from you dhc? I’ll backup the 1.0 one.

/MLS

Originally posted by MLS
[B]I get the user buffer error on this drive too, I dont want to move it all around… Can I get the .bin of 1.1 from you dhc? I’ll backup the 1.0 one.

/MLS [/B]

Yeah, but I need to know your email address.

Bleh, mtkflash won’t recognize the flash type in my 5224a. MTKFlash will read out firmware, but won’t write. It just sits at 00% on 1.55, and 1.48 gives me a bunch of errors instead. Are some Asus drives using a different (non-mediatek) chipset now or something?

Also I flashed to 1.20 and after reinstalling IAA I have major reading issues. So I went back to 1.10. I have to use the Asus flash util since mtkflash thinks I don’t have a mtk drive. I even moved it to a different computer and on its own IDE channel, still not identified flash memory. Whats going on?

/MLS

Have you tried mtkWinFlash?

Yeah I get the same error message. Cannot identify flash type.

/MLS

bump, still having this problem. My Asus is Secondary Master, I do ‘mtkflash 3 W /B as10.bin’ at command prompt, says:

MTKFLASH by Joseph Lin, MTK 1998 (Ver 1.55)

Flash Type : Unknown Flash Memory

Updating 00%.

and sits there till I stop it. But when I hit enter on the command the light on the Asus drive flashes a couple times so I know it sees the drive fine. Is it possible that my Asus has a messed up or non-MTK flash memory?

/MLS

It is possible, though doubtful…

hmmm :confused:

are u sure that your bin file isnt corrupt?

Its possible but why would it say unknown flash type for reading and writing? Alexnoe said he had that problem till a newer version of mtkflash came out supporting his flash type.

/MLS

dont know wich version you have
but i dont think there will be a newer version
else it would be already there, since the current version is pretty old.

When i’m trying to flash my crw5224 cd recorder
I’ve a dialogue box with this message : (in french)

“Seule une partie d’une requête Readprocessmemory
ou Writeprocessmemory à été effectué”

Seems that i can’t decompress the exe files
of CRW5224A_135.exe and ASUSFhB6T4.exe
to flash my drive to 1.35
My OS is Windows XP Pro
I’ve try in Windows Safe Mode
In PIO 4 mode for my drive
In Windows 98 compatibility and others…
Nothing changes…

What can i do ???
please help !

Polo the frenchie

Uninstall any IDE driver you have (IAA, Via 4in1, etc…) and try again. Setting compatibility and/or PIO mode had no effect on my computer (i845PE, Win XP).

Does someone have the latest or any bin file for this drive?

Read the thread and all posts.

All info is there.

Ok, I need help bad.
I must be doing something wrong since others have luck using mtkflash on Asus drives.
I have tried 3 different versions all the way to the newest and all of the different version bin files I could find.
I get is that it is not a identifiable type. some times using the a135 lock up, but will never do anything. I have tried several different commands to no avail even using sw instead of w.
Thanks in advance.

Maybe you need to connect it another way, and jumpering too.