Asus CDRW Problem

For some reason ever since I reinstalled/upgraded windows using an xp home edition OEM sp2 CD my CD burner has been acting up.

It freezes my computer sometimes
It has a hard time reading CDs; especially blank ones; you can literally hear it struggling. It sounds as if it’s found the CD, starts to read it because the (engine?) or disk just moves really fast; like you can hear the cd moving and just activity, but this only happens for like 2 seconds then it stops dead in its tracks. After maybe 4-5 minutes of this happening, it MAY read the CD and not give me any problems.
At times it DOES read the CD, but then the burn process will fail because it does the hesitation thing again as I’ve explained above.

What I have done:

[ul]
[li]I cleaned the CDs
[/li][li]Tried other CDs
[/li][li]Reinstalled Nero
[/li][li]Tried other burning programs
[/li][li]Downloaded the latest drivers for my CD burner
[/li][li]Uninstalled and re-installed the drivers
[/li][li]Blew inside the CD burner
[/li][/ul]