ASRock K7S8X rev 3.0 and Linux

vbimport

#1

Hi guys,
I’ve just upgraded my second computer “the workbench” (it was PIII 500 MHZ slot 1, MainB. GigaByte VIA chipset) with an ASRock K7S8X rev. 3.0 + AMD XP2400+ (very cheap stuff from Ebay) with 256MB DDR Pc3200.

With Windows XP Corporate+SP2 no problem, works fine, but I can’t install any Linux distro.
I have tried 2 different distro: Suse 9.1 and Mandrake 9.2 with the same result: a lot of writing errors on the Hard Disk.

This computer has also been used as a hardware firewall with Smoothwall, but even this one has got the same problems (error was “Lillo – Keytable read/checksum error”).
It looks like there is a problem with the IDE controller under Linux.
With live CD like, Koppix or Feather usb it is all right.

Any suggestions welcome.

The Bios setup of the K7S8X is standard; not one parameter has been changed except the boot sequence and the CPU clock 133MHz (AMD XP2400+ [15x block]).

I also tried different bios [now is K7S8X_2.52A downloaded from you]: with the same result.

I used for different HD for the tests:
• one 20Gb (WD200 Cavair) for XP;
• one 2Gb (WD 22100 Cavair) per Linux;
• one 1,2Gb (CONNER CFS1275A) o 500Mb (Fujitsu M1603TAU) per Smoothwall

Ciao Guido