ASPI layer files don't work

vbimport

#1

I can’t get my burners to work correctly with any of the
ASPI versions that are arround. That includes the Adaptec ones and Force ASPI and even the files that Nero uses. I only have a problem when I want to rip music though. Are there are rippers around that do not need the ASPI files as none of my favorite rippers seem to work without them.

I am running XP Pro.

TIA :confused: :bow:


#2

i thought xp didnt use aspi layers anymore. seeing how it is a nt based os


#3

KenL,

can you be a little more specific?

Can you state the following of your system:

  • cdrw/cd-rom drive maker/model (e.g. LiteOn 52246S)
  • chipset on the motherboard (e.g. Via, nfroce2, i865, etc)
  • ASPI “installers” that you have tried to use
  • Which ripper have you tried to use it with and which error message do you get (or how does the “does not work” appear to you as a user)?

Maybe we can help.

cheers,
Halcyon


#4

Sorry for the delay as I had some system problems that are now fixed. I have to test things out again though. I was using the ASPI layers with a Liteon52x as well as a Samsung DVD and a Sony DVD writer (510A). All of the different versions of the ASPI files have caused some problems.

I am running WindowsXP Pro with the Intel 875 chipset.

Also, I was using Audiograbber and CDex, but I had some problem with EAC that was different then an ASPI one as it had a conflict with MusicMatch JukeBox 9.0 which I use solely to play audio files with.

I really was looking for a ripper that did not need an ASPI layer if such a thing exists. My DVD burner seems very sensitive to the different versions.

TIA


#5

KenL,

you can always use the Nero aspi layer with EAC only, by putting the following file in your EAC directory (you do NOT have to put it in your Windows system directory):

ftp://ftp6.nero.com/wnaspi32.dll

Put that inside your EAC directory and select EAC Options / Interface / Installed external Aspi interface.

Then restart EAC.

Now you should be able to use Nero ASPI in EAC and what ever ASPI you want in other programs.

Please make note however that you are using same ASPI versions inside your system directory and do NOT have ASAPI installed at the same time, as it can confuse some devices (ASAPI, not ASPI, is made by VOB).

regards,
Halcyon


#6

Originally posted by KenL
I really was looking for a ripper that did not need an ASPI layer if such a thing exists.

Of course.
In the same “Interface” tab of EAC that Halcyon said, you can choose “Native Win32 interface”.

Feurio uses the same native interface by default in Win2K/XP (called DeviceIOControl in Feurio). You can change the access mode in Program Parameters menu.
I’ve been using that interface with Feurio for a long time and I haven’t found any difference with ASPI access in Win98.