ASPI issues

vbimport

#1

Guys, some suggestions please. I’m running an AMD box with Win2kPro, SP4. I tried to run Power DVD the other day and it souldn’t play the DVD (Liteon LTD163). I got an error message saying there was a problem with ASPI.

No problem reading regular data or audio disks in the Liteon drive. So, how do I fix this ASPI issue? Can I just run ForceASPI and will it clean up the problem?

Thanks.


#2

Should do. :slight_smile:


#3

Yes should work, although I always prefer not forcing ASPI unless absolutely necessary. If I may suggest removing ASPI completely and then installing a clean version of 4.57 followed by an upgrade to 4.60

I have noticed from past experience this procedure is most effective and has helped many others I have suggested to on cdfreaks already.

ASPI
ASPI4.57
ASPI4.60


#4

Yup, I agree that this is the cleanest and most reliable method of ensuring a good installation of v 4.60. :iagree:


#5

Sounds good guys. So… how do I remove all the existing ASPI and clean up the mess before I start installing the fresh (and hopefully stable) versions? Is there a utility that will go in and remove everything that needs removal?

I also have Nero installed, and I think it has it’s own ASPI. This isn’t going to muck things up, is it?

Thanks!!!


#6

ForceASPI includes a script called KillASPI.bat, you can run this and be rid of the appropriate files. Then be sure to remove all instance of the wnaspi32.dll file from your machine. To remove all files manually look for the following files and delete them:

[ul]
[li]wnaspi32.dll
[/li][li]winaspi.dll
[/li][li]wowpost.exe
[/li][li]aspi32.sys
[/li][li]aspienum.dll
[/li][li]apix.vxd
[/li][/ul]

Source:
http://www.tricerasoft.com/aspi.html


#7

hi everyone
on adaptec site i found a ASPI v4.71 and even a v4.71a2. maybe the latest versions of aspi files (more recent then 4.6 mentionned here) ?? :confused:
where to find the utility to check current aspi version ?


#8
  1. ASPI 4.60 is the best.

  2. To clean the registery > [COLOR=RoyalBlue]RegCleaner, & RegSupreme

  3. How to Install ASPI / ForceASPI 1.7

Once again, no need to run KillASPI :[/COLOR]

INSTASPI - Installs the latest, 4.60 (1021), 
Adaptec ASPI layer on Win9x, WinME, WinNT and Win2K. 

[B]Any existing ASPI Layers will be overwritten[/B] 

#9

As said many many times already, ASPI 4.60 is the most stable and safest, most portable to work with just about all your applications. Newer isn’t always better.

Most ASPI software come with an aspicheck and NeroInfoTool checks ASPI too.

For removal you now have about 3 several ways to proceed from methods posted by members here.


#10

ok got aspi version from nero info tools
and install v4.6 due to many users advice
thanks all


#11

OK, I guess one last question. How will ForceASPI, which installs Adaptec 4.6, interact with the ASPI that NERO installs? Will it overwrite Nero’s ASPI, or will the two coexist? I don’t want to lose the ability to use Nero to burn CDs. But I also want a clean and correct ASPI installation so I can run PowerDVD.

Thanks very much for the info thus far.

ABB 2004


#12

Don’t worry, you’ll burn with Nero as usual, and no probs with PowerDVD (v.4 or v.5, as I’ve never tried others). I used ForceASPI on many systems without complaints from my friends and relatives.


#13

Goto : Nero InfoTool > ASPI tab > ASPI Installation and see for yourself.