Aspect ratios when converting mkv to Blu-ray



Hey, I wanted to ask you something related please, if I may…

So, I went ahead with these particular MKV files and processed them through TSMuxer first and THEN put them through BDRB. Everything came out fine. It didn’t try to re-encode it this time. Now, when I try to play similar AR encoded files in a Blu-ray format, SOMETIMES they allow me to use my television AR settings to adjust the picture. For example, with SOME 1440x1080 Blu-ray discs that I’ve made I CAN change the AR with my television and get them to show properly and the different settings change the way it is displayed. This is of course the way it is with MOST discs you would play normally. But… In THIS case above, when I try to play it on my OPPO Blu-ray player, the AR / picture is basically ‘Locked in’ and no matter what I change my television AR to, the picture is not affected in any way. It just stays stretched to a full 16x9. This has also happened on occasion before. But only a few times. With basically ALL normal Blu-rays, you can always use your television and stretch the picture or squish it or go from 16x9 to 4x3, each setting affecting the way the picture looks. But, in this case above and a few times before, the picture or AR has stayed completely ‘Locked’ in a full 16x9 picture, thus looking stretched horizontally.

Now, my question is, is there some SPECIFIC flag or value within the Blu-ray folder / structure that tells the player to ‘Lock’ the picture or ‘Force’ the 16x9 AR like that? There must be SOME setting or value that makes a difference, because I know that I’ve had other encodes at the exact same AR and they WOULD allow me to change the way the picture is displayed on my television. Obviously, whatever BDRB does when it processes the files seems to lock the picture into an unchangeable AR of 16x9.

I remember doing this with some STAR TREK: TOS Blu-rays of the series. I took some HD 1440x1080 encodes and put them into a Blu-ray format (probably just using TSMuxer alone) and I THINK I remember that they DID allow me to play around with the AR. However, I think it was with the next season of that show, I tried to do the same thing, but this time (with EXACTLY the same 1440x1080 AR) the resulting Blu-rays did NOT allow me to change the picture from a forced 16x9 AR.

Any thoughts…?

Thank you!


Your questions on aspect ratio are getting way off topic in the BD Rebuilder guide, so I moved them into a separate thread.

Aspect ratio discussions can get confusing, and I don’t know the subject well enough to advise you.


I do know that aspect ratio’s can be written into the video stream, or can be set at the container level. Hardware and software players may differ on which type gets priority. So the decoders, whether they are software or in the firmware of a stand alone player, might read them differently.

You might want to try remuxing the mkv files in MKVMergeGUI and set the aspect ratio to 4:3 in it. This will reset the aspect ratio at the container level.

Reworking the video stream is much more complex. I have seen, but never used, a tool for modifying the Sample Aspect Ratio in H264 using command line in ffmpeg. You might also have to remux the output with MKVMergeGUI.


Ah, I learn something new every day I start looking things up about video. 1440 x 1080 is made with rectangular pixels, not square pixels. So it is actually a 16 x 9 format with anamorphic encoding.


Hmmm, most interesting…

I appreciate your time and help! I’ll try the remux with setting the AR and see. I was pretty sure that there MUST be some setting that is locking in the AR. Could be the square pixel thing too; I’ll do more reading myself about that :slight_smile:



Hmmm, this is very confusing. I had asked before about BDRB automatically re-encoding some MKV files because the target size was ample to fit them. Even with ‘ForceNoEncode=1’ (or the proper equivalent, I don’t remember right at the moment :slight_smile: )

I was told by both Neuron2 and Sharc that BDRB must be re-encoding because the MKV’s AR must not be compliant (which they weren’t because as I explained before a friend backing up my Blu-rays incorrectly by stripping out the ‘Black bars’)

So, I’m thinking, 'Oh, that’s great then, so all I have to do (lazily) is simply import the ‘bad’ MKV file into BDRB and it will automatically re-encode and add the black bars to make it compliant, right? And, I set it for High Quality 2 pass. So, I’m thinking, ‘Great! it will fix this and make it compliant and playable on my OPPO Blu-ray player.’

Well… I just did my first file that way and when checking the resulting m2ts file with MediaInfo (BEFORE burning it) it shows the AR to be the original 2.40:1…?!!

So, what exactly was BDRB doing with all that supposed re-encoding then? According to MedioInfo, it did NOT correct or ‘fill out’ the resolution like I had hoped. And, on a side note, the original file was about 14 Gigs including of course the full HD audio; the resulting size was a full BD-25 (which WAS the target size, but I was kind of surprised that it used it all) But, no foul there, I just wonder WHY…?

So, DOES BDRB indeed re-encode a MKV file through ‘Import’ and correct an improper AR or doesn’t it? Is there an additional setting that I need to make it do that?

Also, VERY curiously, if I was told that that was precisely why BDRB was forcing a re-encode earlier, why not now…???

Thanks kindly for any ideas!


I don’t think BD Rebuilder will add black bars to your encode. If it can do this through additional manual controls, I don’t know where those controls are. You may have to use a different tool to add the black bars, then import to BD Rebuilder so you can have Blu-ray format with a simple menu. Or a more reasonable solution is to start over from the original Blu-ray discs.

BD Rebuilder isn’t recognizing a problem in the AR, so it doesn’t seem to be correcting this. There may be a lot of other factors that it [B]does[/B] have to correct in these mkv files to get to Blu-ray compatibility, so that may be why it is re-encoding in the first place. Hard to be sure without examining the files, but your friend may have done more than strip off black bars when “ripping”.

I believe it expanded the size of your videos because of the encoding settings. You used a 25gb target with High Quality and 2 passes. Its going to try to hit that target size accurately with those settings if it has to re-encode. Wasteful of bitrate, but won’t hurt anything. Try a CRF encode next time.


thank you most kindly for your reply!