Artec WSM-52x CD-RW

vbimport

#1

Bought a Mad Dog 52x CD-RW drive which turns out to be Artec WSM-52x with firmware version 1.0. But it’s really bad, incompatible with many cdr’s. I’m wondering whether there are some firmware upgrades to it. Artec website has nothing about this drive’s firmware.

Thanks.


#2

This firmware update is for the WRR-52X model, but the WSM-52x may be just the same drive sold in another part of the world.

Anyway here is the link for version 1.16 for WRR-52x: Firmware file and flashing program.


#3

hello man!

I update wsm-52x firmware using in wrr-52x v1.16
but…#$@#%

can you dump your wsm-52x v1.10 firmware file to mail to me?
I don’t backup my orginal firmware file.

please~~~~

Thank for your help.

my e-mail:u8735045@alumni.ccu.edu.tw


#4

Can I also have the original firmware?
If anybody would be kind enough to send the the original firmware for the artec wrr-52x to writedustin@yahoo.com, I’d greatly appreciate it.


#5

Hi. I also killed my Artec WSM-52X by using the wrong WRR-52X firmware. Can someone please send me the correct firmware for WSM-52X? (I know… I should have backuped my firmware…but I learned my lessons now).

Sincerely,
John


#6

http://www.ultima-elec.nl/Firmware-update.html


#7

code65536, thanks for your help.
Actually, the firmware I downloaded for WRR-52X is the one that flash into my currently dead drive.

For the past few hours, I tried various firmware to revive the CDRW. The best success I had so far was Lite-On 52x24x52x (CDR-6s52), which allowed Bios to recognize the drive. Of course, the drive didn’t work :(.

I acatually called Artec (located in Tawian) and tried to get the firmware, but I had hard time communicating with the office.

Oh well, did anyone buy a Mad Dog 52X CDRW from Officemax around December? If so, can you please send me your firmware? Of course, I should really have backuped my original firmware…

Thanks,
John:bow:


#8

Oops! I just noticed the “WSM-YG52” model number and thought that was what you were looking for. Upon closer inspection, it’s not really a 52x drive despite the model. Sorry 'bout that.