Artec 32x12x48x <<<<<problems

HI!
i got a artec 32x12x48x cdrw series and my computer recognizes it, but when i try to burn something none of the recording software see it, also when i put a cd in the light stays on all the time. i don’t know if it myght something with the firmware, or it is just damage. thanks for any comments.

What recording software do you use?
And which version?

When your drive is detected in the Bios and under Windows,
but not by your recording software you should update the
program and install/update your ASPI-drivers!

i’ve used the newest version of easy cd creator platinum and nero, and they see the burner but can’t record to it, because every time i put a blank cd in the light turns on it never shut’s off. any suggestions??
thanks

Maybe your drive doesn’t like the CD-Rs you use :confused:
Have you already tried it with different discs?

What CD-Rs are you using?

I’ve had two of those Artec pieces of Junk.

In all honesty I dont think they’re worth the packaging, neither worked even after RMA’ing one.

My problems were that the writing Software recognised it but the light just flashed constantly as if it were trying to recognise the inserted disk.

Heres the Artec Website:

http://www.artec-electronics.de/

Loads of info there…NOT!!!

Remove it from your PC and give it to the kids to play with and buy something decent.

Sorry for the negative reply but those Artec things really are cr@p!!

Originally posted by rickpad007
i’ve used the newest version of easy cd creator platinum and nero, …

Could be a problem of Easy CD Creator and Nero being installed
together on the same computer :confused:

I would uninstall both programs first, and then go with Nero only!

And…I would agree with CHR15 that Artec CD-Writers are of
rather bad quality :frowning: