ARGHHH, angry with my writer :((

vbimport

#1

I have a problem with my writer,TEAC W552e. I mean I’ve tried multiple 48X and even 52X certified CDR. But it won’t burn them at more than 32X speed. The only medias that will write at 48X are Maxel and DataRight. I’ve tried upgrading the firmware from 1,05->1,09 but didn’t help.
Now my friend has the same writer but he got it with a firmware version of 1,10 which I don’t even know that exists. Anyway he can burn all CDs at 48X or 52X that mine would only write at 32X.
Could anyone help me?
Oh yea, and I’ve got another problem with PRINCO CD-R which are also 48X certified it will ofcourse only burn them at 32X :frowning: and after they are burnt my writer has trouble reading them although all other CD-ROMs that I’ve tried putting it in work flawlessly. But if my friend tries to burn these CD’s , he can burn them at 48X and they work flawlessly even on my recorder.
My writer is around 5months old and my friend’s writer is 4months old so I can still RMA it.


#2

Owh, come on!
Could anyone at least gimme a hint?

And how come my friend with the same recorder has a firmware version of 1,10?


#3

www.teac.co.jp

Search for the downloadable version of the 1.10 firmware there.