AOPEN No Longer Recognizes DVDs -- HELP

vbimport

#1

I purchased an AOPEN DUW1608/ARR drive this past April. It has been a good drive to me up until about a week ago. I popped in a DVD for my typical viewing pleasure, and it failed to recognize the DVD.

Drats.

It still recognizes CDs, though–which i found odd. I don’t recall having done anything peculiar with the drive that would cause it to fail to recognize DVDs. I have updated the firmware to the latest available, but the problem persists.

All suggestions are appreciated. Take care.

clint


#2

I would install the drive in another PC to see if it is the drive itself or the system that causes this problem. If the drive still fails to read DVDs in another PC, I’m afraid it’s dead.


#3

Hi Clint,

I recently had an old DVD drive that did the same thing. It worked fine for CD’s, but didn’t recognize DVD’s at all. I tried taking it apart and cleaning the rubber tire that spins the discs and the lens, as this has helped me to fix many non-working drives in the past, but no go. You could try cleaning the rubber tire (you usually can clean this with a qtip, with the tray open, to avoid taking it apart- cleaning lens though, you probably would need to disassemble and be VERY gentle with the lens)

You can TRY cleaning, but if it doesn’t work, the drive is probably dead meat.
Good luck, good thing drives are pretty cheap nowadays! :slight_smile: