Aopen DVD1648/AAP Pro vs Toshiba SD-M1912 compared

CDRInfo compared the Aopen vs Toshiba .

Personally I would go for the Toshiba, because of DVD-RAM reading support.

CDRInfo said this about the drives:

Conclusion:
The AOpen DVD1648/AAP Pro and Toshiba SD-M1912 DVD-ROM drives are two of the most popular readers currently available. So it was highly intersting to test and compare them both in the one review.

Both drives were fast while reading CD media. The AOpen drive reported lower (ie better) seek times while the Toshiba had slightly higher speeds due to its 52X support. Their performance was similar when reading recordable CD media.

With DVD-ROM single layer media, their performance was also close where at 16X the difference was negligible. However, when the disc was double layer, the result was very different. Here, the AOpen proved to be much faster, with average reading speeds close to 10X, while the Toshiba a little above 6X. We saw the same behavior with recordable and rewritable media. The AOpen drive finished the DVD±R/RW readings closer to 10X max and having an average of 7X, while for the same tasks the Toshiba reported 6.3X at the end of the test and an average of 4.7X.

The average ripping speed with CSS DVD-Video, as reported by DVD Decrypter, was 8.1X for the AOpen drive and 6.8X for the Toshiba. Although the AOpen proved to be faster than the Toshiba drive, when the inserted media is DVD-RAM, only the Toshiba can read it as only it supports this advanced format.

One of the most important charactristics of a reader is its error correction capabilities with CD and DVD discs. As far as the CD format goes, overall, the Toshiba drive had better performance since it read more reliably two out of our three test discs.

DVD error correction was good with both drives but we would like for it to be better. We didn’t like the reported error from the Toshiba drive with the ABEX TDR-845 nor that of the AOpen with the ABEX TDV-541.

Our DAE tests confirmed that AOpen supports 40X DAE speed while Toshiba 32X. Both drives support C2 information while the score for the Advanced DAE Quality test was full points for both drives. However, neither of the drives managed to successully finish playback of the 90min or 99min test discs.

The Key2Audio protection is not a problem for either of the readers. On the other hand, the CDS200 is. The Toshiba drive could not recognise the disc at all, while the AOpen recognises the contents of the disc but the ripping process goes on forever.

The AOpen drive also had fast performance with all the protection types we tried, even that of SafaDisk. The Toshiba was extremely slow with the specific protection while with the others, just average.

Finally, both drives cannot perform writing quality scans. Also, there is no hacked firmware revisions for both drives currently, that can remove the region control or increase the reading speeds.

I have both the toshiba 1912 and the Aopen 1648 and in the same machine with the same burner using CloneDVD2 and AnyDVD the toshiba averages between 28-34 min to rip and burn a movie depending on the movie. the AOpen takes between 12-16 min.

My new Aopen AAP Pro is a lot faster than my Toshiba SD-M1712 (with anti-rip lock firmware J004) at ripping DVDs. A quick compare here.

I must have a bad drive. I recently upgraded from the Toshiba 1712 to the 1912, as the 1712 was getting noisy, and couldn’t read the second layer of dual layer DVD+Rs. The 1912 has been horrible. It takes longer for the movie to start than the old 1712, of the maybe 20 movies I’ve watched, 3 have paused at various places in the film, it screws up with the seemless branching on the T2 Extreme Edition, and tends to close as your trying to get a disc out.

Will I have better luck with the Aopen 1648?

Hi I just bought two of the exact same aopen 16X dvd burners and tried to put them in the same PC. I got an error upon setup saying that the devices weren’t able to install because of the duplication. Finally I put a different one in with it and solved that problem. Now I have another problem… I am using 4X Phillips Media (have been for a year) 16X burner and nothing works. It says successful burn BUT it only plays in one of my players. Any help??? Is 4X too slow, this is a brand new burner. I got 4X media because when I burnt on 8X in the past I had the same problem… HELP!!!

The problem is the player most likely.

The player plays the movies fine when using my NEC 2.4x or my AOPEN 12x and the same media… I’m lost on this one!!! I was thinking that maybe 4x is too slow for a 16x burner… any thoughts?