AOpen DVD reading woes

vbimport

#1

Hello folks,

I’ve been having one hell of a time getting my AOpen DUW1608 to read my burnt DVD+R media (Phillips brand, btw). Side note: commercial DVDs read properly.

In my internet travels I’ve been reading that lots of people have had trouble with this specific drive. I’ve updated the firmware (last available revision I could find: 1.11, from 2005…) and that didn’t change a thing. I tried using firmware for the DUW1616 and still no luck. Read on…

The odd thing (well, from my perspective) is that I successfully burnt content onto the DVD+R media using this drive, and the DVD+R reads fine in my laptop drive. So the drive can burn a working DVD, but it can’t read it.

Actually, it sort of reads the disc. After putting the disc in and ejecting it a good 15-20 times the DVD+R’s label showed up in My Computer… but it was listed as a CD-ROM, not DVD! (Side note: commercial DVDs appear as “CD-ROM” too!) The used space on the disc reads 3.8 GB (the correct size of data burnt), but opening the drive I discovered that only one .txt file was displayed - the rest of my burnt content doesn’t show up.

Any ideas? I’ll post more info up if needed, just ask. And thanks =).


#2

Welcome to the forum. Try unistalling this drive via the device manager, then rebooting the computer. Just let Windows reinstall the drive by itself and then try to read a dvd again. Hope this helps?


#3

I’ll try uninstalling from the device manager but it won’t help me with my chief problem: I’ll be turning this machine into a Linux box.

I just burnt and tested a distribution - my laptop gets to the installation screen fine, but the DUW1608 drive causes this computer to hang indefinitely. Something tells me it’s the hardware itself that’s bad?