Anyone with a toshiba dvd-rom SD-M1712 please respond

vbimport

#1

If u have this device in the same IDE channel with a cd-rw device then PLEASE do a write transfer test with Nero Cd Speed at your cd-rw. (it is a simulation it doesn’t burn the cd…). Please report if the line that nero cd speed will show is a) straight or b) with spikes.

In my case I get too many spikes when dvd is connected. When I disconnect the dvd I get a straight line. I contacted toshiba and they told me to exchange my dvd, but I have the impression that they didn’t look into it too much and that it is a firmware error. But i need someone else report the same error so I can prove my theory.

Please anyone with a SD-M1712 help me. It should only take a couple of minutes…


#2

SDM1712 has been reported to have compability issues with UDMA on some computers. Try disabling UDMA in bios for the channel your toshiba is connected to, but !leave UDMA on in windows!


#3

there is some serious kind of problem with this device. All the guys here in a greek forum report and verify my findings. Haven’t tried yet what your suggestin. Looks strange… If I disable UDMA in bios how will I able to leave it in windows? Windows should only detect PIO mode… Whatever. I’ll try it and report back.

By the way: Where did you find this solution from?

Thanks for the reply anyway.


#4

It’s not a 100% guarantee solution, I just thought it might help you. Several guys including me had problems with 1712 which were solved by disabling DMA in bios so it’s possible that it will help you too.

Windows should only detect PIO mode…
Just disable it in bios and choose “UDMA if possible” in Windows.


#5

yes u are right. The problem is that I have a Nforce2 chipset and there is no option to disable UDMA or force PIO through BIOS. I disabled it through windows control panel and the problems caused to my recorder device were gone.

Unfortunatelly PIO mode makes the M1712 reading cds at max 16x so this is not really a solution.

I have contacted Toshiba and waiting for a reply… What do u think is the reason for this problem?

Faulty hardware or faulty firmware?


#6

What do u think is the reason for this problem? Faulty hardware or faulty firmware?
I think it’s a design flaw. Teac W540 also had one when it would not work properly on some maschines with UDMA enabled (this is actually how I got the idea - the symptoms were very similar so I thought if W540 works fine w/o UDMA, then maybe 1712 would).

Anyway, I don’t have nForce2, but what I have in my bios is PIO MODE - Auto and UDMA - disabled, in windows device manager I have “UDMA if possible” set. This way my 1712 reads at full speed (48x) and no problems whatsoever.

Try looking more carefully through the bios, maybe you missed the option to disable UDMA.


#7

uninstall the nforce2 ide drivers and use the windows default ones.


#8

with and without nforce2 drivers, problem remains. It is a device’s issue no questions about it. I hope it is something it can be fixed with a firmware update…

If toshiba was an ownerable company should either fix it with a firmware or recall the product. That’s my opinion. But this would happen only if someone here at cdfreaks or some other sites post a review of the product that actually proves that there is a problem. Then toshiba may consider that…


#9

update:

I did a search and unfortunatelly my Asus A7N8X doesn’t have an option for selecting UDMA or PIO mode. The mainboard does that by itself. However I did find a UBER BIOS that gives this option so I am going to try it and report back my findings.

2nd update: flushed uber bios and disabled UDMA in the channel the dvd is connected. XP now sees it as Multi-word DMA. You were right. The problems were eliminated and the dvd can read up to 48x!

Now I am going to take my revenge for this a**hole at toshiba support who was telling me them “I am the first with that problem and I should have my device RMAed”. I was insisting that all the devices have this problem but he wasn’t “thinking so”. F*cking amatuers I say!

Thanks for the advice thyfleshconsumed. U saved me.


#10

unfortunately when I connected again the devices in the same IDE the spikes also returned. The toshiba was in PIO mode. but that didn’t help… I posted the issue in a greek forum (I live in greece) and all the people with this device have the exact same problem!

here is steliosdj posting some pics:
1712 idle

1712 with cd inserted

1712 disconected

georgeadams also posts:
1712 idle

1712 with open tray

1712 with disc inserted

1712 disconected

As you can see all the above use different recording equipment and still have the same problem… PLEASE anyone with this device make a write transfer and report your findings.


#11

I had that problem but put the Toshiba on the end of the cable on the first channel and the dyberdrive on the second. I just changed the drive letters in windows to keep the drives in order. I have the jumpers as master slave. The problem is gone.