AnyDVD RPC2-error on all DVD / -drives

Hi everyone who knows the problem and/or the solution…

I installed AnyDVD 1.6.1.5 and it worked very fine with the newest CloneDVD-Version. Since some XP Security-Updates I always get the same error after starting AnyDVD.

A box appears that says:

  1. DVD is soiled, please clean or
  2. DVD is damaged or
  3. DVD is not RPC2 (but have to be) or
  4. DVD-Drive is´nt adjusted to read RPC2-Discs.

…but nothing true!

I tried everything:

  • I used the newest AnyDVD-version (1.6.3.7).
  • I switched my DVD-Drive (Toshiba M1612) to RegionFree-Firmware and official firmwares.
  • I Re-adjusted RPC2 of the DVD-Drive(s)
  • I tried many other DVDs.
  • I tried another DVD-Drive (Artec DHM-G48) with regular and region-free firmares.
  • I tried changing all AnyDVD-options.
  • I reinstalled Software and DVD-Drives
    …everytime same error message after insertion a movie-DVD.
    Files on DVD-drive are´nt accessible since starting AnyDVD and CloneDVD says: “Sheduling …error…bla” at beginning of reading disc.

System Configuration:

  • XP with SP1a
  • DVD-drives(s): Toshiba M1612 or Artec DH-G48 on Secondary Master
  • Burner: LG-4040B via USB
  • Autoplay functions all OFF
  • DMA enabled

Perhaps some of you competent guys can help…PLEEEEEEASE!
…and sorry for bad, bad english…i´m DSCHÖRMÄÄN…;0)

MANY Thanks for help.

LAEGGA

I kept getting that with V1.6.1.5 :confused:

Couldn’t find the cause of the problem, so uninstalled the damn thing and use Decrypter to put files on HD before using DVD2ONE.

If you used VIA/INTEL/whatever Busmaster drivers - get rid of them.

Use the Busmaster drivers which came with XP.

Hi Olli,

that´s a possibility. I changed from VIA 4.36 to 4.37. I´ll try that tonight and will post a reply tomorrow.
“Thanks” for the moment.

Laegga

Hi Olli.

Okay, you´re great!
Via 4.49 doesn’t work. I changed to 4.47 and/or 4.46 and it works. So, don’t use 4.49!!!

Thanks for this little but important clue.

Laegga

Originally posted by LaeggaEis
[B]Hi Olli.

Okay, you´re great!
Via 4.49 doesn’t work. I changed to 4.47 and/or 4.46 and it works. So, don’t use 4.49!!!

Thanks for this little but important clue.

Laegga [/B]

You’re welcome. I can reproduce this problem, but not by installing the 4-in-1 drivers 4.49, but the IDE Miniport 3.20b available here:
http://www.viaarena.com/?PageID=340

The differences between these drivers is explained here:

http://www.viaarena.com/?PageID=342

According to VIA, the IDE Miniport is NOT installed by default with the 4-in-1 drivers on 2000/XP, only on NT4, maybe this is a bug in the installation routine?

This driver causes:

  • CloneDVD not to write anymore (complete failure)
  • CloneCD BIG performance penalty while reading (due to frequent retries)
  • AnyDVD not to read anymore (complete failure)

I am currently working on a workaround for this problem.

For the technical interested:

Most elby programs read 16 sectors in one go, usually 162048 = 32 kBytes. This is done to comfort most weird hard- and software.
The VIA IDE Miniport driver reports a maximum transfer size of 64kBytes (fine), but strangely it also reports, that it only supports 8 page breaks. 8
4096 bytes CPU page size = 32 kBytes. All would be fine, but:

Windows XP (and only XP, not NT/2000) has a bug in the calculation of the maximum possible transfer length.
The elby tools correctly request 32kBytes, the VIA driver supports this, but the ScsiPort.sys kernel dll assumes the transfer is too big. Maybe due to a wrong compare (> instead of >=). Why the VIA driver reports only 8 possible page breaks puzzles me.

A new version of ElbyCDIO and the tools mentioned above should offer a workaround for this problem.

I suggest to avoid the VIA miniport IDE driver for the moment.

I have no idea, why 4-in-1 drivers 4.49 seem to install the miniport on some system configurations, although VIA says in their documentration, they won’t do this: http://www.viaarena.com/?PageID=342