AnyDVD 6.0.9.2 - "No DVD Drive Detected"

I was running AnyDVD 6.0.8.2, no problems at all.

When 6.0.8.5 came out, I upgraded to that, and I got “No DVD Drive Detected”:

After struggling with it, I rolled back to 6.0.8.2, worked great again.

I watched the threads here about issues with 6.0.8.5 and such, and finally today deceided to upgrade to 6.0.9.2, figuring all of these issues would finally be solved.

However, I’m getting the exact same behavior as with 6.0.8.5… “No DVD Drive Detected.”

Notes / attempts:

  • System was rebooted both before and after AnyDVD 6.0.9.2 was installed.
  • Tried “Safe Mode”
  • Tried uninstall / reinstall. I use Ashampoo Uninstaller to log application installs which will wipe out every file and registry key that they put on the system. Uninstall with AnyDVD uninstaller, then use Ashampoo to thoroughly clean the system.
  • Tried uninstall / rolling back to 6.0.8.2. Everything works fine.

Still can’t solve the problem.

Why is this happening to me? What do I look for? How do I fix this?

This happens when AnyDVD believes it has been modified (Virus infection, or modified by a crack).
Please contact SlySoft customer support so we can find a solution. Make sure to quote your serial number (Settings->Information).
Thank you!

“No DVD Drive Detected.” another crack diversion, very creative guys. :wink:

I Thought it was but wanted to be sure on that.

Woah! Piracy is bad. No excuse to pirate the app when you can have a free 21 day trial, especially since there are some free alternatives you can use until you can afford the purchase price.

Oh man.

Dear Pelvis Popcan: Noone is absolutely sure if you are using a cracked version or not. Only you know that. If you are, you know what to do ( buy it ) if you are not do as James has suggested contact Slysoft with your information and your problem will be resolved.

Yes
send SS your key for analysis
they will fix it and send it back to you
or otherwise help you out in you problem

make sure in addition you have
rebooted
not running any registry/exe blocking softeare such as Zone Alarm etc
not having conflicting bootup progs

It’s not cracked… I love it when I get nailed by stuff intended for the bad guys :stuck_out_tongue:

E-mailing support…

Dear Pelvis Popcan: James just said that the issue you are having is usually caused by the files in AnyDVD being changed. Nobody accussed you of anything. I beleive you are having an issue that needs support from the company ( Slysoft) so e-mail them with your registration information and I am sure you will taken care off. :iagree:

Pelvis
Dou you have Zone alarm running?

yes, zaq is right, zonealarm 6.5xx pro seems to cause some problems with anydvd.

I use zonealarm and had problems also. Problems downloading, problems no drive detected. I used crapcleaner and registry mechanic. No more problems.

Does not for me I have had zonealarm 6.5 all along and never had problems with anydvd. I do not have anydvd set to autostart and I do not have it checked to check for new updates but when I have loaded new one it is set for these and works then. I alway uncheck the autostart and the new updates since I do not want things running in the background that I do not need all the time and I only want programs going to sites when I let them.

My computers has only zonealarm running at startup and I even went to zonealarm and stopped 99 percent of the things that it sets to access the internet. Sure makes my two computer run faster,burn dvds faster and work faster on the internet.

samlar, are you using the pro version? I use the free version and don’t have problems, but when I tried the pro version, I had the problem that pelvis popcan mentioned.

security suite version When I install anydvd each time at the end zone alarm always ask something like do I want to let anydvd to be set to start up when windows starts I alway say yes to any of the items the after boot just uncheck the autostart. could be that people are not saying yes to the items that pop up when a program like anydvd is install or have zonealarm set to always block these things without telling them. I have my alerts in zonealarm set to show only high leve alerts. another thing people could do is disable their internet and zonealarm load the program then restart both. I for one have used zonealarm so long I know how to control it.

I haven’t put in a support ticket yet… still trying to fix it on my own. :slight_smile: I want to try uninstalling every Slysoft application first then reinstalling them all.

One weird thing happened… for an hour or so, my net connection went down. Usually when I uninstall and reinstall on a new version release of AnyDVD (my own preference), I get “your trial period has expired” before importing my key. But when I did it during my troubleshooting when my net connection was down, it said I had the full 21 days… that must mean AnyDVD is communicating with a server at Slysoft? Maybe that’s why people running Zone Alarm get the problem? Because it’s trying to do some kind of validation with a server at Slysoft, and if it can’t, it disables the drives? I have absolutely no idea… I’m just speculating… :slight_smile:

i’m not sure if anydvd has done this before, but sometimes the slysoft guys makes it so that they reset the 21 day trial, but i’m not sure on which program & i’ve not seen it for a while.

if you do have ZA, read this thread & see what i had to change to make my key work.
http://club.cdfreaks.com/showthread.php?t=201938

Everytime an updade is released, I uninstall my registered copy of AnyDVD and install (without rebooting) the new update. Sometimes I got he same “NO DRIVE DETECTED” message shown in Pelvis Popcan post. But after rebooting the system, AnyDVD operates perfectly well.

This happened with several updates, not only after 6.0.8.2 release.

Moral: Allways reboot after installing a new update.

GB

I got it to work finally, I didn’t need to contact support! :slight_smile:

For future people who have this problem, here’s my info:

First, I uninstalled all Slysoft applications - AnyDVD, CloneDVD, CloneDVD Mobile, and CloneCD.

I use Ashampoo Uninstaller to take a system snapshot before then after a program install. This logs all file changes, additions, and registry changes and additions.

I used each program’s uninstaller from Control Panel -> Add/Remove Programs. After each uninstaller, I then loaded each log file into Ashampoo Uninstaller and deleted any file and registry changes the uninstallers didn’t get.

Finally, I insured all of these files and registry keys were no longer on the system:

C:%systemroot%\system32\ElbyCDIO.dll
C:%systemroot%\system32\drivers\AnyDVD.sys
C:%systemroot%\system32\drivers\ElbyCDIO.sys
C:%systemroot%\system32\drivers\ElbyDelay.sys
C:%systemroot%\system32\drivers\RegKill.sys
HKEY_LOCAL_MACHINE\SOFTWARE\Elaborate Bytes
HKEY_LOCAL_MACHINE\SOFTWARE\SlySoft
HKEY_CURRENT_USER\Software\Elaborate Bytes
HKEY_CURRENT_USER\Software\SlySoft
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class{4D36E965-E325-11CE-BFC1-08002BE10318}\LowerFilters
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Control\Class{4D36E965-E325-11CE-BFC1-08002BE10318}\LowerFilters

(They weren’t; Ashampoo Uninstaller got them all.)

After doing a final reboot for good measure, I then installed all four SlySoft products in the order that they were released, oldest to newest:

1 - CloneCD
2 - CloneDVD
3 - CloneDVD Mobile
4 - AnyDVD

After rebooting, everything now worked normal!

Some speculation:

When I installed AnyDVD 6.0.9.2, as with all previous installs, I got “Trial period expired” before entering my key. But when I was troubleshooting last night and did a reinstall when my net access was down for around an hour, I got the full 21 day trial. This leads me to believe that when you run AnyDVD setup, there is some communication with a server at Slysoft, perhaps it creates a hardware based hash and stores it on the server, and that’s how it can track trials and expirations. I’m totally guessing on that though. I was able to successfully uninstall 6.0.9.2 and install the new 6.0.9.5 today. My net connection was up, and I did get the full 21 day trial again before importing my key.

The other thing some people have pointed out is that they can get the “No DVD Drive detected” error if they are running a firewall like Zone Alarm. That may be due to AnyDVD not being able to “phone home,” or it may be a driver conflict. Again I’m guessing.

I believe my problem may have been due to an incorrect version of one or more driver files on my system, maybe ElbyCDIO. AnyDVD will update elbycdio.dll from 6.0.3.1 to 6.0.5.1, and it will also update elbycdio.sys. Both the old and new elbycdio.sys have the same version number (6.0.0.0), but the updated file is 15,440 bytes and the old one (from CloneCD I think) is 8,064 bytes. (This is the kind of thing you can learn when you use a product like Ashampoo Uninstaller. :)) Since uninstalling all Slysoft applications then reinstalling them in release order from oldest to newest fixed the problem, I feel this is a likely conclusion (but is still a guess).

I know it isn’t zone alarm to stop this ordeal as I use the ZA security suite. However this can make it back to a trial as it is a new version. I have the 3 bars on mine to allow comunication to their server myself as their is no reason not to trust them. I think what people might be doing is denying access and not realizing it. :doh: