*ANY* Cd-r burning software that enables Unicode filenames?

the same with copytocd ?

hi lapinou,

YEAH !!! same with copytocd/dvd !!! i haven’t burnt the cd yet with copytocd/dvd (only burn a test with nero). but copytocd/dvd will add the files to the copytocd/dvd manager. the add window displays cyrillic as it should. when added the mangager displays it correctly too. so everything should be fine!

greetings,

derebo

You’re welcome Derebo, and I’m glad to hear you got it working. Sorry that in my original post I didn’t realize XP’s regional settings were laid out differently than 2000’s. But, in the end it all worked out, and that is what counts.

cfitz

I had no problem with typing russian file names, but WinAMP does not play these files, not even from hard disc (yes, I have installed russian fonts and russian keyboard layout).

:confused:

Originally posted by alexnoe
but WinAMP does not play these files, not even from hard disc (yes, I have installed russian fonts and russian keyboard layout).

Just an example :

Alexnoe, have you set your system locale to Russian? I know you said you installed Russian fonts and keyboard layout, but that often isn’t sufficient to make all programs work fully with Russian fonts (or whichever language one is trying to use). I have found that setting the system locale is the key for maximum compatibility.

For example, I have installed the Japanese input method editor and fonts on my Windows 2000 system. With these I can view Japanese web pages, I can read and write Japanese email and documents, I can name files with Japanese characters, etc. However, my system locale is still set to English (United States), so many programs have trouble working with non-English filenames. But when I switch to the Japanese system locale those same programs work fine.

I still have Russian support installed on my system from my earlier work with Derebo, so I ran some experiments. I renamed an mp3 file with a pseudo-Russian name (as I freely admitted and BoSkin reiterated, I don’t know Russian. But I did “name” the file with Cyrillic characters). I then attempted to play it under various conditions and this is what I found:

System Locale = English (United States)
Windows Media Player 7 - plays the file
Winamp 3 - does not play the file (displays “???” question marks)

System Locale = Russian
Windows Media Player 7 - plays the file
Winamp3 - plays the file

This is quite similar to the behavior of Nero and other burning programs: to fully support non-English character sets the system locale must be set appropriately.

So, if you haven’t yet tried changing your system locale, please do try. Unfortunately the instructive link I posted for Derebo seems not to be working anymore. If you are having trouble setting your system locale, let me know and I will try to help.

It would also be interesting to see what Windows Media Player does with your Russian filenames when your system locale is not set to Russian.

cfitz

Oops. That link must have been temporarily down. It is working again now:

http://home.attbi.com/~kagamix2/xp-compatible/japanese_setting.html

Follow the appropriate instructions in “Step A” to set your system locale. Pay particular attention to the very last step (“Language for non-Unicode programs” in the XP instructions, “Set default… System Locale” in the 2000 instructions).

cfitz

However, enabling non-unicode support has its consequences. First of all, all unicode text you would enter for the enabled language sometimes would not come out in unicode (it would be in the language’s own codepage instead). For example, since Nero is not unicode compliant, if you enter unicode into Nero with non-unicode enabled for Russian, the text you enter will be in the Russian codepage. When u turn off non-unicode support, the text you entered will now be in gibberish.

I won’t pretend to know exactly how Nero is handling the various character sets internally, but I can report that it does appear to properly encode unicode file names in the Joiliet extension when the above procedures are followed. The Cyrillic characters in the example files I pictured above continue to be properly displayed as Cyrillic characters even when my system locale is returned to English (United States).

cfitz

It isn’t nero that is doing the conversion but instead the fact that it is burning to Joliet thru the imapi burning service i think, which is unicode compliant, so that windows does a local codepage -> unicode conversion on the fly. I do wish that microsoft would make it possible for you to choose the codepage to use with each program when it loads, instead of for the entire system as a whole on boot.

Originally posted by OCedHrt
It isn’t nero that is doing the conversion but instead the fact that it is burning to Joliet thru the imapi burning service
I doubt that, since as far as I know Nero uses its own internal burning engine exclusively. Nero was around long before the IMAPI service, and you can run Nero with the IMAPI service disabled (in fact disabling IMAPI is often recommended to prevent conflicts when using third-party burning software). Moreover, the examples I showed were done on a Windows 2000 box, and Windows 2000 does not even include the IMAPI service. But, regardless of exactly what is creating the unicode Joliet filenames, the point is that they are being created when you follow the above instructions.

Originally posted by OCedHrt
I do wish that microsoft would make it possible for you to choose the codepage to use with each program when it loads, instead of for the entire system as a whole on boot.
That would be convenient, but there may be architectural issues that make it impractical. I don’t know.

cfitz

> IMAPI service disabled

in fact, if you don’t do this then you run all the risks associated with the MS SCSI Passthrough interface. NO-ONE can write an ASPI like Adapatec, in fact no-one comes close and IF you don’t use an Adaptec adaptor then you’re insane or maybe don’t understand SCSI like most of China, which is most of the world. But, I digress - google for the problems.

Observant members and lurkers, that’s not to say that others are non-observantly stupid btw, will have noticed that buring apps now use their own burning ‘layers’ or ‘engines’ which work - CloneCD, Alcohol or sometimes work - Patchin’ Coughin’ engine or you get a choice, or non-choice - DiscDump, bao etc.

Apps are free to use or not use IMAPI which is the front end for the Passthrough SCSI Interface. Most don’t and shouldn’t.

@OCedHrt

you read as though you know what you’re talking about (like cfitz does too, btw!).

Heh, i guess none of you guys use windows xp. go ahead and try burning with imapi burning service disabled. NERO WILL FREEZE. as far as i can tell, imapi burning service is required to burn cds in windows. REQUIRED. 2k doesn’t have this service because 2k itself cannot burn cds. oh, and 2k3 also requires this services, and it comes default disabled (don’t forget to turn it on! =P) so too bad for 2k lovers hoping to upgrade to 2k3 =P and the conversion is done by windows, not nero. I can choose the appropriate language and reboot and burn only if i were burning one language. however, i have multiple asian languages on my system and it simply doesn’t work. but this issue has already been address by the copytocd team and it now works flawlessly for me.

and, furthermore, ur the one who has no idea what your talking about. all those layers still have to use the imapi burning service. the imapi burning service is not a scsi passthrough. starting from windows 2k an aspi scsi passthrough is no longer included. that has nothing to do with the burning service. even with the burning service programs like clonecd and alcohol, nero even, cannot access the cd drives, they require an aspi layer. trust me, i’ve tried. imapi burning service disabled = any burning app freezes on burn.

ok, i take part of that back. just tried on xp after installing it. disabling imapi burning service works fine. so in win2k3 it must be a compatiblity issue. the burning engines of current programs do not work in that os. however, i do think it is the os that does the conversion, since this also takes place in other programs. thanks for alerting me to this! goes and saves more ram

Originally posted by OCedHrt
Heh, i guess none of you guys use windows xp…

…bla-bla-bla…

…imapi burning service disabled = any burning app freezes on burn.

:confused: :confused: :confused: Poor you !

Btw, next time if you want something to be added to your previous post(s) ( the 3 examples above ),

just press on the button. :wink: [fixed!]

I have files (name in chinese characters) to be burn using Nero burning rom. I know that changing the regional settings enable the viewing of unicoded characters but i do not want to alter it as it affect other program!

I try using njstar to view but it didnt works! Help!!!

note that disabling the IMAPI service on some XP systems will cause a considerable lag when you rightclick on a file or folder and choose to copy or paste it to another location. can also interfere with drag and drop functionality. i have discovered that IMAPI is best set at manual unless you achieve some obvious advantage in doing otherwise.

biggercrap: changing the regional settings allow windows to convert the unicode to the associated code page, big5 or gb in your case. An alternative is to use microsoft’s apploc progarm to change the locale for Nero temporary. It works for me, though not the ultimate solution. Copytodvd supports unicode for the most part, but I constantly run into small problems in this regard when I test their new versions.

Ghosters: I have the imapi service completely removed from my Windows cd, never had that problem.

where to get the apploc