Another slow burning 2500A

vbimport

#1

First, let me thank everyone here at the cdfreaks for maintaining such an excellent site!

Well, I purchased my NEC-2500A from NewEgg after reading posts and reviews on the Fatwallet several weeks ago. Since then, I have burned several dozens of movies on 4 different brands of dvd-r, first x2 discs than x4 discs. They all play well on three of my stand alone players. However, I realized that 60+ minute burn time on x2 did not improve on neither of the x4 disc brand (memorex & imation) I purchased recently. Being new to the DVD burning, I thought it was my PC (P4 2.4Ghz with 533Mhz fsb and a pair of PC3200 512MB RAM running at 333Mhz) but from what I am starting to learn, that doesn’t seem to be the case. It has XP Home and I am using the latest Nero Ultra and DVD Shrink.

After reading the troubleshooting guide along with few other posts, I changed the NEC drive from a slave to master which seemde to take the burn time down to around 45 minutes on x4 burns which does not improve using the x6 burn settings (memorex). I also made sure DMA setting and the Transfer Mode is set to “DMA if available” on both the primary and the secondary IDE channels. However, “Current Transfer Mode” shows “PIO Mode” on both. I’ve trid to uninstall the IDE channel NEC-2500A is on (primary) but when the PC in rebooted, window reinstalls to return to how it was before. I also flashed the original 1.06 fw to Herrie’s beta 7 (THANK YOU!!! ) but burning Memorex disc at 6x speed still yielded same burning time of 45 minutes.

Next thing I want to try is enabling the “EDI mode” in the Bios as someone had suggested before. Can someone explain to me how this can be achieved? Also, is there another way to uninstall the IDE channel? I am so lost on this…

Thank you in advance for your help on this matter! :bow:


#2

Hi
This is how I do it on my PC.
Re boot, hit F2 key and it boots into set up mode.
Key down to Integrated devices, hit enter then IDE drive UDMA. Make sure its turned on.Hit enter and save changes and exit.
Then go into device manager and enable it there.
Hope this helps.


#3

Sorry can you explain what you mean my ‘EDI mode’, is this a typo?

If you haven’t done already also update your ASPI layer to the current version (www.adaptec.com).

If you motherboard provides you options for PIO and UDMA (my old ASUS one does), then make sure that the PIO mode is set at 4 and the UDMA is set at 2. (Please disregard if not relevant)

With the last point if I’m wrong please correct me and post the appropriate information.

chrome


#4

Originally posted by bamo
Hi
This is how I do it on my PC.
Re boot, hit F2 key and it boots into set up mode.
Key down to Integrated devices, hit enter then IDE drive UDMA. Make sure its turned on.Hit enter and save changes and exit.
Then go into device manager and enable it there.
Hope this helps.

I’ll try it first thing when I get home from work…hope it works :bigsmile:


#5

Originally posted by chrome307
[B]Sorry can you explain what you mean my ‘EDI mode’, is this a typo?

If you haven’t done already also update your ASPI layer to the current version (www.adaptec.com).

If you motherboard provides you options for PIO and UDMA (my old ASUS one does), then make sure that the PIO mode is set at 4 and the UDMA is set at 2. (Please disregard if not relevant)

With the last point if I’m wrong please correct me and post the appropriate information.

chrome [/B]

chrome,

I’ll try updating my ASPI layer from the adaptec site though I don’t know a thing about it. As for the EDI mode, I don’t think its a typo…as I got it from another person’s post here… :confused:

Thanks and I’ll keep you guys advised…


#6

ASPI layer should really have no effect on your drives burning ability.
The obvious solution for you here is to get your DMA working.
What motherboard/chipset do you have in your PC?
Reboot and watch the screens closely.
It should tell you which key to press in order to enter SETUP.
Read your motherboard manual for more details.

If this doesn’t work, you may want to try a new 80 wire UDMA IDE cable.


#7

Okay guys…here’s what I found out. Nero’s DVD InfoTool show that DMA in enabled in the primary IDE channel to which the C drive (30 gb) and the 2500A are connected to . E drive (80 gb) which is the second hard drive where I store the encoded video files to burn do not show the DMI enabled. So, I encoded a movie onto the C drive for the first time than burned two disks at x4 (generic disk) and x6 (memorex x4 disk). Times showed 15:30 minutes and 10:26 respectively! :bigsmile: Both movies play perfectly. However, when I encoded the sames movie onto the E drive, it went back into the granny mode and took over 45 minutes at x6 burn speed. :a

If I can enable the DMI on the secondary IDE channel we might have solved the problem. How can this be achieved? Going into the SETUP using F2 key and turning on ‘IDE drive UDMA’ does not effect the secondary channel…(thanks bamo for the step by step instructions) :confused:

Thanks guys for all your help~


#8

First make sure your hard drive is set to NTFS not Fat 32.
Second not all hard drives can be DMA enabled,check your booklet or do a search with Google.
There is a tool you can download to force DMA if its not compatible. Will check back later.


#9

Both C & E HDD are set to NTFS…

Found directions how to ‘force DMS mode’ on google by hacking the registry. If that doesn’t work, my next option will be to try switching IDE ribbon to 80 wire UDMA IDE cables…

This is turning out to be a major task :Z

Much thanks for continued interest and support guys!


#10

Sounds like it could be your cables.
I’m off to Thailand tomorrow 2 weeks holiday, you should have it sorted by the time I get back. Have fun.


#11

Let’s try to clear up a few bits and pieces here.

ysspo has posted elsewhere that his machine is a Dell Dimension - Dell tend not to use trashy IDE cables, though it’s always possible he has a damaged cable.

Adaptec ASPI - this really is better avoided unless you need it - I believe wesociety will agree with me on this. Adaptec ASPI does cause problems (for example, it’s a near guaranteed BSOD on my system when trying to mount an image using Nero ImageDrive with Adaptec ASPI installed - Adaptec ASPI doesn’t cope very well with the number of drives changing ‘on the fly’). There is a reason why Adaptec have dropped all support on Adaptec ASPI, and no Roxio burning software uses it any more (Roxio used to be part of Adaptec).

A lot of posters are saying ‘solve your burning issues - update to the latest ASPI’ quite blindly. Most modern applications do not need ASPI (KProbe being a notable exception). The low level aspi32.sys driver is very invasive and can cause all manner of weird problems, as I’ve posted about in more detail in the past. If you need to burn as a non-Administrator, the Nero BurnRights utility will allow SPTI (and hence Nero) to work as users of your choosing (or Everyone if you wish).

It shouldn’t really matter whether hard disks are NTFS or FAT32 - personally I believe NTFS is the better of the two options, but there are possible side-effects of switching to NTFS that have to be thought about. Without third party utilities (or a reformat), changing a FAT32 partition to NTFS is a one way operation.

The most common cause of issues with slow and unreliable writing on an internal writer is DMA problems as wesociety indicated.

David


#12

Originally posted by DavidW
Adaptec ASPI - this really is better avoided unless you need it - I believe wesociety will agree with me on this.

:iagree:
We only recommend ASPI 4.60
If you have it, uninstall Adaptec ASPI and/or use a utility named KillASPI to get rid of other ASPI versions…


#13

Trying to force the DMA by hacking the registry did not work as system returns to PIO mode upon rebooting. I ordered a pair of round 80 wire cables on Friday and they should arrive in a day or two. If they do not work at enabling DMA mode on the second IDE channel, at least they’ll imrove the air flow in the case. I’ll post how they work out… :smiley:

PS: David W, thank you for posting your reply on the other thread on this topic. I’ll just post here and let that one fade away as I did not start it and the OP seems to have solved his issues.


#14

I also have the ‘enhanced airflow’ IDE cables :wink:
See HERE


#15

Originally posted by wesociety
I also have the ‘enhanced airflow’ IDE cables :wink:
See HERE

Enhanced airflow is all I got out of the new cables if that…

Still got lousy PIO modes on both slaves (E drive & liteon dvd drive). Can anyone HELP? :sad:


#16

Check with support.dell.com to see if you have the latest BIOS for your machine. Especially if Windows has been reinstalled, check that the Intel Chipset Utility has been installed (if you post the ‘name’ of the IDE controller from the Device Manager, I should be able to tell you).

David


#17

I have had the exact same problem as you. For some strange reason the secondary IDE channel switched by itself to PIO mode from UDMA. Trying to force it back into UDMA by using different hacks/regtweaks did NOT help. So here is what I did - and still do from time to time when WinXP decides it’s time to run in PIO mode :slight_smile:

  1. Open the device manager
  2. Remove the devices attached to the secondary IDE channel
  3. Remove the devices attached to the primary IDE channel
  4. Remove the secondary IDE channel
  5. Remove the primary IDE channel
  6. Reboot

Upon restarting WinXP will detect the new/missing hardware and set both channels on both IDE ports to UDMA. This works for me every freakin’ time. Hope it works for you.

Regarding cables: Remember to use 80-wire cables for UDMA66/100/133 devices (the NEC is however only a UDMA33 device).

Cheers,
Peter


#18

Tried pdu’s suggestions twice without avail. Everytime, slave devices on both of the primary and secondary IDE channels returns to PIO mode upon rebooting. I really had my hopes up on this one… :sad: :sad: :sad:

Any other suggestions folks? Getting ready to give up…


#19

Have you tried DavidWs’ suggestion?
See if there is an update for your mobo bios…


#20

ysspo,
i had the same problem with my nec 1300A but able to restore ultra dma 2 transfer. i hope this works for you.
i took out my nec drive and placed a cd-r drive in the same ide channel. reboot the pc and my cd-r drive was detected with ultra dma 2 transfer. turned off the pc and took out the cd-r and reinstalled my nec 1300 A drive. viola. ultra dma was restored in my nec drive.