Another PTXL issue?

I have a 760 as master on the secondary ide channel, and the 716 as slave. If I turn on my external hard drive (usb 2.0), the two burners disappear, while the two internal hard discs appear under plug and play hardware, three times each.

Can anyone confirm this in any way?

Is it showing correctly in Device Mangler?

Windows Device Mangler :wink: shows them all correctly, only the PTXL don’t. I uninstalled the PTPro software, so I can’t cross-check.

Edit: Rescanning the devices in PTXL fixes the issue, of course.

No. The external HD shows up and everything else stays as it is. Disconnecting leads to a position “Other PnP Devices” remaining in the device list. Rescanning devices gets rid of that.

PTPXL is PnP capable/compatible. PTP is not. So with PTP you’ll always have to “rescan devices”.

I don’t have that problem. I currently have Plextors in SATA and IDE, also 2 HDD on USB2.0.

Pic1: All drives including USB2.0 HDD connected, and PTPXL is launched. Note that the USB2.0 HDDs are under “Other PnP Devices”.
Pic2: I turned off the 2 HDD USB2.0 and turned them on again. PTPXL recognized them without me doing manual rescan (it takes a while though). Other Plextor drives are still there. :wink:

Another weirdo.

  1. Normal view.
  2. Card reader plugged in.
  3. Card reader plugged out.




I can confirm that one. I get 2x “Generic storage device” for each slot in the reader. One of each has no drive letter, the other one does.

Also before my HDs are represented per drive. After connecting the reader they are represented by partition (drive letter).

Thanks for the hint with the partitions. Are the burners still visible?

oops forgot that :slight_smile: Le me sum it up:

  • Burners stay when external USB-HD is connected/removed. I tried two HDs (Maxtor Onetouch II 3.5" and Iomega Silver Series 2.5"
  • Burners dissapear when a cardreader is connected and do not come back when removed. I tried with three different USB-cardreaders (lexar, hama, motionflash) and all produce the same effect.
  • ‘Rescan devices’ brings everything back to normal in either case and also seems to ‘sort’ devices correctly.

Something is definitely amiss here.

Well, it might be a usb issue. I forgot to mention that my external hd is a trekstor with its own three-port usb hub. And there ARE two external hubs already … I don’t know what’s going on here.

I can confirm this but I did the other way around.

  1. When I unplug the usb card reader, burners stays.
  2. But when I connected the card reader again then burners dissapear and all my HDDs (SATA and IDE) are located in “Other PnP Devices”.

Rescan fixes everything.

This seems to be proven then. Thanks a lot!