Another pioneer 109 problem

vbimport

#1

This problem im having is very often.
i got the pioneer 109 oem with 1.17 firm

yesterday i tried to burn 2 riteks g05, i inserted the dvds and 2 programs nero and recordnow were unable to detect the blanks, they said there was no dvd in the drive, so i tried another brand of blank dvds, and same problem, both programs said there was no dvd in the drive.

So, i rebooted the pc and miracle, after that recordnow and nero detected the blank dvd inside the drive…

Wtf is going on?
i got this same problem sometimes when i insert a BURNED DVD WITH DATA inside on the pioneer 109, the drive starts to spin the dvd for a couple of seconds and windows does not detect the dvd, ( inside My Computer icon the dvd drive icon appears but doesnt detect the dvd and there is no VOLUME LABEL like for example gcmospeadadvd1 volume label.

sometimes if i right click on the dvd drive icon, the drive starts to spin again and then it reads the dvd, detects the volume label and the data inside.

doods this 109 drive has serious issues.


#2

Ritek IMO aint the best read other posts and flash the 109 to 1.40 firmware, fixes lots
Yes 109 had issues so i kept my 108, but thanks to new firmware above im getting 109 on monday.


#3

I got a 109 fitted last week, and I’m using Ritek g05’s and everything working fine, using 1.17 firmware and 1.40 firmware, maybe you have a loose connection or something, or a bad drive


#4

Never had this problem.

Have you updated all the firmware. Is it correctly installed into your system?


#5

You are the one with an issue if you do not flash to the latest version and complain!


#6

make sure your IDE cable for you 109 drive is a 80 pin not 40 pin cable and see if that helps.


#7

LOL
Before saying that find a proof!
You probably never heard about Auto-Insert-Notification.


#8

Ok fact is the 109 did have major issues and was not as good as the 108 till it seems this new 1.40 firmware, hense im getting it on monday and swapping out my perfect (on all firmwares) 108, even talking drop in burinig speed from 16 to 8 until someone does hacks like NIL’s.

I can admit the 109 was IMO pos till now, maybe others cant or maybe they has 0 probs but i doubt it was all user errors, so all i can say anyone on the 109 non retial fancy model, please flash to 1.40 then make a new assessment.

I will say it again, IMO i dont rate Ritek, there is far better media like Verbratium even pioneer rec this for overspeeding on stock firmware (when 108 was launched).