Another error code 19 problem

vbimport

#1

Howdy,
I would appreciate any help you guys can give me, thanks in advance!

I’m running windows xp home with sp1 on a Medion MD2900 laptop. It came with a Toshiba DVD-ROM SD-R6112 dvd burner.

Everything worked fine until I installed a trial version of a dvd-authoring program called FastEZ CD/DVD.

Upon installation, it couldn’t find my dvd-burner, and the program wasn’t what I was looking for so I uninstalled it. Now my system can’t use my dvd burner or my Alcohol120% virtual cd drive. Device manager gives me the error: “Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19).”

I’ve tried un/re-installing the drive, restoring the system to an earlier point, and the fix that is found elsewhere on this forum: http://club.cdfreaks.com/showthread.php?threadid=76175

So far, nothing has worked, and short of re-installing the entire OS, I’m out of ideas.

~Jeff


#2

You have tried deleting/uninstalling the IDE controller from device manager and then restart and let windows install it automatically?
Do your laptop have an intel chipset on the mainboard?

If so try installing: Intel driver chipset drivers


#3

If you’ve followed the “fix” in the other thread mentioned to remove all the filters on the CD/DVD drive class in your registry, you will almost certainly need to follow that up by uninstalling all writing software on the machine, unless you know it doesn’t use filters. (Nero 6.3.1.6 doesn’t, InCD 4.1.5.10 does, Feurio 1.67 doesn’t, Roxio Easy CD Creator almost invariably does - don’t know about any other software).

If, with the writing software installed, you can then get the drive working as a reader, reinstall just the software you want to use. I’d start by uninstalling just the CD/DVD drives in the Windows Device Manager, and rebooting - then if that doesn’t work, following OC-Freak’s advice. The meaning of Code 19 is documented here in the Windows XP Professional Resource Kit online (it doesn’t matter much that you’ve got XP Home here).

Personally, if I have to manually edit the filters, I try to remove just the ones I want to, rather than removing them all.

David