Another AD-7201A?

did a back up install of my pc,running windows xp media center
had the OPTIARC DVD RW AD-7201A installed and working perfect before i did backup install.
now it works not so perfect
if i go to my device manager it is shown and working.
i can convert and burn dvds with convertx 2 dvd .not if i open another 3rd party software to burn cds or dvds it’s not even recognized i have uninstalled drivers and rebooted still nothing

i flashed it when i first installed it tried to flash to latest firmware and i get
target optiarc AD-7201A is not found correctly.
so there you have it i tried my best to tell all i know
i sure hope someone can sort this out for me
thanks in advance

update of somethings i have come acoss
entered bios this morning
and this is what i saw(to the best of my memory cause i didn’t write it down)
primary ide channel 0
secondary ide channel 0
primary ide channel OPTIARC DVD RW AD-7201A
secondary ide channel ******cd-rom
primary ide channel Wd external hard drive
secondary ide channel 0

now when i select my OPTIARC DVD RW AD-7201A it shows no setting at all
that its not able to do SMART ----->(i don’t remember what this word was)
the only one really recognized was my external hard drive
i mean it didn’t recognize my hard drive either…but it’s working cause im on the pc now???

still no one has any answers
when i run binflash gui>no devices are found
though i can burn with musicamatch jukebox,convertx2dvd,droppix
still no devices found man i’m scratching my head on this one
someone plz help