Annoying printer problem

vbimport

#1

I’ve got an HP Laserjet 1018 printer which has worked very well over the last few years with very light usage. Today it decided not to work with my main computer, but I don’t think it is the printer’s fault, in fact, I know it isn’t.

I’m using Win 7 64 bit, fully updated.

The problem is that any print job goes to the print queue and almost instantly disappears. The command to print is simply not being conveyed to the printer. I’ve run the MS Printer Fix-It tool and it says there is no problem anywhere. I’ve run the HP printer troubleshooting diagnostic tool and it says there is no problem to be found. I’ve updated the drivers for the printer. And I’ve changed the settings in the Print Spooler service to always restart the service in the event of a failure. None of that has done any good.

I hooked up the printer to my secondary computer and it works just fine from it. Same printer, same drivers, same operating system…very annoying. Printing through the network from the main computer through the secondary failed, with no error message available anywhere.

Any clues?


#2

I’m guessing that you are using the USB connection , if so have you tried using a different USB port?


#3

You’ve probably already checked this . In Control Panel/Printers :
R. click on this printer & see if it is the default printer.
Then check “Use printer online” .
You might also take a look at your "Printing Preferrences " & "Properties"
to make sure the settings are like you want them.

On my HP printer not a laserjet I had a bad ink cartrige even when it tested OK.


#4

Changing usb ports doesn’t affect the problem. Printer properties are the same (or have been changed to be the same) in both computers. One works, the other doesn’t.

The only difference is where the printer is attached. It shows up as the network printer in one, and is directly connected in the other.

In the main computer, no printer jobs are being carried out. This seems to me to be an issue in the Print Spooler service, but I can’t seem to get any of the diagnostic programs to agree with me on that.


#5

I have limited experence with printers so others advice would probably be better.
Have you tried a reboot just to see if that loads the spooler correctly?

You might run a chkdsk to make sure you system files are OK.

I have a HP GUI called HP Solution Center . If you have this have you tried to print from there?

Also in Vista the File pulldown has a “Print Preview” have you tried a print from there?
If Windows 7 has this.


#6

One thing worth trying is clearing out the spool memory. To do this, stop the Spool service, go into your OS drive, then Windows -> System32 -> spool -> PRINTERS. Delete all files in here (if any), then start the Spool service again. Usually this folder is blank when all the print jobs are complete.

Another thing you could try to determine whether it’s the Spool service or the HP printer driver is to is install CutePDF, which is a virtual printer. This functions like a printer, but the output is put into a PDF file. If you’re not getting a PDF file when you print something to CutePDF, then it’s the Windows Spool service, otherwise it’s the HP drivers.


#7

I goggled some & found this:
http://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/print-spooler-keeps-crashing-in-windows-7-ultimate/f47b10d6-fba4-412e-bf49-5daaba31c601

It has Seán’s first suggestion .
I have a different PDF virtual printer & it is useful to check if print works with it.


#8

Thanks for the ideas guys. There was nothing in the folder Sean pointed me to. CutePDF worked fine for making a pdf file, so I started concentrating on getting rid of any traces of the HP drivers.

I’ve gone through some of the registry entries found in cholla’s links and got rid of anything related to HP.

I’m in mid process of reinstalling the printer and drivers. Lets see if this works.


#9

No. No luck.

May just use a restore point and see if that helps.


#10

This is from the link I posted . It looked like a different cause.
I seem to have fixed the problem on my HP Windows 7 64 bit machine. First, I checked the “Event Viewer” and noticed a recurring print spooler error. When I looked at the details I saw it was related to a decommissioned PC that the printer was previously hooked to. I searched the registry using regedit for all occurrences of this decommissioned PC’s name and deleted two separate entries in the registry.

So a look at Event Veiwer might show something.


#11

Oh things went to hell in a handbasket soon after my last post. A restore to a Windows restore point was useless, so I did a restore using my older Clonezilla image backup…there’s another program on my [B]never to use again[/B] list. :a

The image works, but won’t boot correctly and no amount of fussing and fuming in recovery fixes it. It boots just fine if I put a clone of my Windows install disc in one of the optical drives.

Not a big deal. I was thinking of getting an SSD anyway. This trainwreck of a day just pushes that thought closer to reality.

Oh, and by the way, the printer still doesn’t work.


#12

I have Vista & I’ve had very good results with AcronisTI .

I was curious if you looked at Event Viewer before the “restore” attempts .
Kind of a moot point now.


#13

Yes, I did try to find some error messages early in this fiasco. Didn’t see any related to the printer.


#14

Ha! Fixed the boot problem. Now back to the printer.

Listen to me printer, I’ve got a sledgehammer and I know how to use it.


#15

Kerry when you find the solution to fixing the printer post what you did to fix the boot too.
Did you try to Print the PDF file CutePDF created ?

One of the posts said it was files containing “flash” in the PRINTER folder .
Once deleted it solved the problem.
I found .SPL files there but wanted to view them before deleting . All but one were 0kb.
The viewer wouldn’t read those but would the one that was 500kb . It was something I printed or tried to print a while back.
With some testing a .SHD & .SPL folder load in the PRINTERS folder when a print in the print preview is finished. Apparently sometimes they don’t self delete.
The ones I deleted were causing no problems for me.
They did for the one poster in the link.
This may not help but shouldn’t harm anything to delete them.


#16

You already disabled the spooler and checked the event viewer?