Android KitKat BlueTooth broken

vbimport

#1

I have a Nexus 4, which is running KitKat 4.4.2
I got new car last week ‘Vauxhall Astra Excite’ which has Bluetooth as standard.
I can pair the Nexus 4 no problem with the car, but neither dial nor answer works from the controls on the steering wheel or the buttons on the Infotainment system.

Tried it with my hubby’s IPhone 5 which works no problems, and it also works with my daughters Samsung S3 mini which is running JellyBean.

Googled the problem, and it seems that KitKat has some serious Bluetooth problems.
Is there anyone else here having problems with KitKat BlueTooth?


#2

Not something that affects me Dee as I haven’t got an Android phone but some people have had success by disabling the 5GHz WiFi band which would seem to suggest that there may be some interference issues between the two.

I presume you’ve already done this sometimes unpairing and repairing can fix this issue as well.

[B]Wombler[/B]


#3

Yep tried all that.
The number that is calling comes up on the Infotainment screen, as does the network my phone is connected to.
The phone just isn’t answered when I press the answer button on the steering wheel, and just continues to ring. I have also worked out that it can’t dial a number because is can’t read the directory in the phone.

Everything works as it should with the iPhone and S3 mini.