Am I stuck with "hacked" firmware for my LiteOn drive? Codeguy?

vbimport

#1

Hi all!

I have a Lite-On 1633S that I flashed to a 1653S using a firmware made by the “Code Guys”. I did this about 7 months ago. The firmware I used is:

1653S.CS0C.patched-cf.exe

And it allowed my 1633 to think it was a 1653 with no problems. However, I do notice that my drive has trouble reading some types of media and the new 16x DVD-Rs I purchased are only ripping at 8x (even though some 12x DVD-Rs burned at 12x just fine.).

So, I wanted to look into updating my “CS0S” firmware to something newer. I downloaded the CS0P firmware (official LiteOn release) and it let me flash with it. All seemed good except when the update process was “done” the light on the drive was still flashing. After a reboot, it was still flashing and would not recognize that a DVD was in the drive (I did not have a DVD in the drive during the flashing).

I was a little worried, but I was able to reuse the “1653S.CS0C.patched-cf.exe” firmware from CodeGuys and thankfully it let me revert to the older version just fine.

So… my long overdue question is, how do I proceed from here? Because my firmware is hacked, does that mean I can not use any future firmwares unless they are also hacked? I thought the “magic” of the Code Guys firmware I used was its ability to make the 1633 think it was a 1653 (which have identicle hardware) but since the 1653 official firmware didn’t take, I’m guessing there is more to this…

To complicate this, it looks like the CodeGuy has moved onto BenQ drives… :frowning:

Am I “stuck” at CS0C? At this point, I’m thinking I should have stuck with stock firmware and waited for a LiteOn release that would allow more media types.


#2

I guess you never read the readme that came in the CS0C package that you downloaded? The readme points to a crossflashing guide that explains everything that you need to know about the crossflash and about things like the process to update to a newer firmware.

Unfortunately, due to technical glitches at rpc1.org, the server is down, but the crossflashing guide is mirrored. You can find the mirroring information here: [post]1055508[/post]


#3

Sorry for my spamming by posting this on two sites. Thank you for taking your time to reply to both.

Here is the contents of the readme.txt file that came with my CS0C:

--------------------------------------------------------------------------------
We are in no way associated with LiteOn, and this patched firmware is in no way
associated with or supported by LiteOn.  Loading this patched firmware will
technically void your warranty.  We take NO RESPONSIBILITY for anything that may
result from the use or misuse of this patched firmware.  USE AT YOUR OWN RISK!
--------------------------------------------------------------------------------


For more information, please visit http://codeguys.rpc1.org/oc.html

Thanks again for your time and thank you so much for the firmware I’ve been using for the last 7 months.


#4

chuckle CDRI is not our sister site. :stuck_out_tongue: I replied there just to clear up the incorrect things that I saw with LtnFlash.

Although the readme is simple and almost contains nothing of substance, the link to the cf guide is really the most important part of it, and although that guide has been down for a few days (but it’s mirrored), it was online several months ago when you first downloaded and used the package. I’ll admit I sometimes don’t read the documentation until I start having problems, but in the future, when doing things like this, you might want to read it before doing anything, not after. :wink:


#5

you are absolutly stuck no where!!!
get the latest omnipatcher (thanks to the Codeguys) and make your 1633S a true 1653S. That way you will be able to use any 1653S FW straight from liteon site!!!

If you want to revert back to 1633S just get any 1633S crossflash enabled FW from the codeGuys and your drive is back to normal!!! you will be able to use any 1633 FW from liteon!!!


#6

I think you meant to say XFU, not OP. :wink: XFU is the one to make the crossflash permanent…


#7

What does XFU stand for? :confused:


#8

Oops. I actually meant to say EPU and not XFU. :o

OP == OmniPatcher
EPU == EEPROM Utility (what I meant to say)
XFU == XFlash Utility


#9

How do you use XFU to make the flash permanent?


#10

You can’t. That’s why I said in my post that I meant to say EPU instead of XFU. :stuck_out_tongue:


#11

I also have the 1633S drive but my problem seems to be different than yours. Maybe you should try to flash back to the old firmware. It worked for me…kinda :stuck_out_tongue: The writing speed became slower and I have absolute no idea why that happened


#12

Their site is back up and they have a patched version of the 1653 firmware (CS0P) for the 1633. Works like a charm! :smiley: I guess LiteOn still doesn’t support these 16x Memorex DVD-Rs however… they still only go at 8x, but in general the drive is doing great and I love how the LED lights up red now during a burn.

Perhaps you should give their newer firmware a try like I did.


#13

either apply a crossflash patch using Omnipatcher
OR
use EEPROM utility to convert your eeprom in to 1653 making the crossflash patch redundant. that means you can just flash stock 1653 firmware