Alot of trouble with Sims2 crashing, hardware?

vbimport

#1

Hi everyone :slight_smile:

Not sure if this is truly hardware related, I think so but let me explain the circumstances.

I’m looking at a friends computer, she bought Sims2 and can’t get it to play. The game loads, but when you try to load up a family, the loading screen comes up for 10-15 seconds. You CAN load one of those empty neighborhoods, but you cannot MOVE a family in. :confused: If you do, the game crashes out and says the application has crashed and has to exit. Then boots you to desktop.

First thing I noticed once she brought her computer over, was that she didn’t meet the RAM requirements- needs 256, she had 128. So we bought her another stick to make 384MB.

The system is:

eMachines D2244 -has 2.2GHZ celeron, 40GHDD, now 384MB RAM, but doesn’t have the original mobo in it. Awhile back, her mobo died, and her husband took it somewhere to get fixed. The only things I see on this board to identify model was: d33007 and vc37.

I did some searching and found out vc37 is a mobo made by FIC. There seems to be two versions, one with AGP slot, one without. Hers doesn’t have one. :sad: So anyway the next thing I was suspecting was the onboard video. She went and bought a Gainward Pro/660 TV/DVI. It’s a Geforce FX 5200 PCI version. I loaded up the drivers, and still the game crashes.

I’ve done alot of things to try and fix this:

  • She didn’t care about her stuff, so i wiped out her drive and reinstalled XP.

  • I’ve disabled and uninstalled the onboard video drivers in Windows, BUT the weird thing about this mobo, is I can’t find out how to disable this onboard video in the BIOS. The ONLY jumper is the clear cmos jumper, according to the manual as well. And there is absolutely nothing about disabling it in the bios menus either. The only thing you can do in bios, is chose 1MB or 8MB (shared RAM with Windows) for the video to use (so really she has 376MB instead of 384 when it’s set to 8MB in bios).

-Been to the Sims site, followed everything they said about crashes. Shut down all background processes that I could, put switches in the game to make it run in a window and with no sound. Uninstalled and reinstalled the game fully.

-Had to load her recovery CD when I reformatted the HDD, and unfortunately it loads all the drivers for the onboard vid automatically. I went to driver file details for the onboard vid, and removed all the files it used. Reinstalled Sims2 again and still no go.

Can anyone give me any ideas? Is the onboard video maybe still conflicting being half working as it is (bios enables it, shares ram with Windows, BUT is disabled in device manager and it’s driver files gone even). Any ideas I’d really appreciate, this is drivin me nuuuuuutz :a

:slight_smile: :slight_smile:


#2

According to page 39 of 52 in the pdf on-line manualthere is a feature to disable the on-board video in the BIOS.

It’s under Integrated Peripherals Menu and the option is called On-Chip VGA and you should set it to disable.


#3

OK figured it out, found a couple more files related to the onboard vid. Deleted them, reinstalled the game and finally it works. Stupid recovery CD’s, I hate how they give you no choice but to load all their crap along with Windows.

The computer is much faster with the more RAM, the video is better with the fx5200, and she had other issues with her PC, so it needed a clean install anyway. It just sucks that I had to spend all that extra time. And all because when you tell it to uninstall the video (and I did it properly) it leaves some crap behind that screws up the whole works. lol oh well, maybe one day, Mr. Gates with make computers REALLY FULLY uninstall things when you tell it too… nah


#4

btw this is your board right:
http://www.fica.com/Upload/Content/Products/P240000048/vc37.jpg


#5

Yes, that’s the one, except theres no AGP slot (solder marks, but no slot), and that jumper you see to the left of the RAM slots is not there. But thats the board.

Does’nt seem likes theres really a way to disable it, maybe you can’t on the non-AGP version board?

If she woulda had a regular XP disc, instead of that recovery CD, I never woulda had a problem. I hate all that extra crap they make you install.

I still would like to know if it’s possible to somehow disable it on this version, so it wouldn’t eat some of the RAM. But it’s working now, and I can set the vid to 1MB in bios to minimize the amount it wastes. Thanks for your effort though xtacydima, appreciate it :smiley:


#6

Hey Rose I’m having exactly the same problem . Wich files you deleted to make the PCI card work fine ?