Age of Mythology issue

Hello,

I am a newbie and found my way here because of problems I’m having running my ORIGINAL (purchased legally) version of Age of Mythology.

I’ve searched the other posts and don’t see a similar question.

The problem I’m having is this: the game installs without error, but when I run it, it crashes to the desktop. I’ve updated all my drivers & asked for help in Aom forums. The reason I’m posting here is this: when I run a, umm not sure I can say this here, nocd creaked (misspelled on purpose) version of the program it runs fine.

So, I know my hardware is capable of running the software, so no fair saying update my video drivers.

The issues SEEMS to be with my CD drive - which led me here.

I have a Plextor 708a, I’ve read that this game uses safedisc (ver 2.7?) copy protection. Is it possible my CD drive just can’t read games that use this type of protection?

If so, if I back it up with one of the programs I keep seeing mentioned (Alcohol?) that it will work?

Thanks for any insights/advice you can share…