After uninstalling magic iso my dvd recorder is corrupted

hello,
this is my first post in this forum so i don’t know if i’m posting in correct section but i really need urgent help.

a few days ago i installed magic iso and magic disc for mounting an .uif file
after i’m done i sucsesfuly uninstalled both programs because i didnt really like them.
then the problem started; now neither my dvd recorder or daemon tools which i use for mounting iso files can’t read or mount disks and iso files(i also tried various other mounting programs but no chance with 'em either). i’ve spend hours for searching for a solution but no luck yet. can you guys help me a bit if you experienced the same problem or have an idea for getting over with this situation (any link to guides on this matter should help too) i really can’t format my drives before i back up some files so i’m really in need of your help.
thanks in advance :slight_smile:

Here is something to try: Reinstall Magico ISO and Magic disc, download this program, http://www.revouninstaller.com/. When you run the program you will see your add/remove section of Control Panel. Right click the programs to Uninstall and let revo find the registry entries and any files associated with Magic Iso and mark all for deletion and select delete. I’m not saying this will fix your problem, but it’s something to try.

Maybe this does help: http://support.microsoft.com/kb/314060

whappo, i tried it but didn’t work thanks anyway
mciahel i’m checking it i will let you know the results later

edit:
btw all iso files and dvds are read as empty disks when i try to mount/use em if it matters