After Crossflashing 160P6S > 165P6S cannot read DL discs

[qanda]This thread is about the Lite-On DVD Recorder. Click here to see full specs[/qanda]I was having problems burning Ritek D01 media in my Lite-on SHW-160P6S drive so I upgraded the fimware, no dice, so then I read that it was possible to crossflash the drive using the EEPROM utility. I did that and upgraded my drive to an SHM-165P6S. Tried reading some discs - no problem. Tried writing a DL disc - worked great (as in, no power calibration errors)!

But - trying to read these DL discs (even a DL disc that I burned successfully when the drive was a 160P6S) doesn’t work. The drive shows empty, and even CD-Roller cannot detect a disc.

Any suggestions?

update- i placed the burned disc in my junky mitsubishi dvd player and it works flawlessly. So this drive can burn Dual Layer, it just can’t read the discs it burns. ??

aha! Too slow, Internet!

The solution was to re-flash with the official Lite-On firemware (xflash). Something about the .bin firmware is fishy, maybe?