Advise Please: New ASUS 1608-P dead?

vbimport

#1

I could really use some advice on my first DVD drive. I was really looking forward to this and wanted an accurate drive (speed was not as important), so I chose this product after careful review.

This ASUS 1608-P is one day old. It won’t play a CD without chopped up audio and when I ran CDex to extract .wav files from an audio disc it threw hundreds of errors. That .wav file output was also choppy. It won’t play a DVD at all.

I changed the region to United States, since no default region was initially shown. It still really doesn’t show what region to which it is set. Perhaps it didn’t require a change at all.

NeroInfoTool at this point recognized the drive properly with a recent, but not fully up-to-date firmware version (1.17)

I attempted to update the firmware to 1.40 directly from ASUS and it was unable to update due to an error. Now Nero InfoTool shows the drive with a firmware of 0000.
I redownloaded the firmware and attempted again to no avail.

I am running the Nero 6 OEM that came with this retail packaged drive and updated it to Nero’s current version from their website. That software looks fine.

The drive is set to master on IDE2 along with a Yamaha FX1 CD-RW set to slave which operates properly. Both are DMA enabled.

The Yamaha CD-RW works flawlessly. I love that drive. It extracts audio like a swiss watch and never threw one error when run through CDex.

WindowsXP-Pro
Asus P4PE mb
two 80GB Maxtors on IDE1

Any advice would be truly appreciated. Is this drive headed back to ZipZoomFly for a swap-out?


#2

No nibbles. Anyone?
Thanks-


#3

Sure sounds to me like the drive is faulty - and even more so now after the failed firmware update. Take it back and get it replaced.