Advice needed on how to save poor wh14ns40 killed by lack of experience- EDIT: SOLVED! SUCCESS WITH INFO


#1

So here is my original post in the dosflasher thread:
“I seem to have killed my wh14ns40 service code ns50, it is recognized and opens tray but cant read anything. At first, I crossflashed to wh16ns58, successfully, and the issue appeared. I tried to revert to wh14ns40- issue persisted, upgraded firmware to 1.03, same issue, but now also cant flash anything due to error message(protection). Is there anything left to try or clean OPC data?”

Also, don’t have a backup dump, so would be happy if anyone with full dumps/ or complete firmware with eeprom, of wh14ns40 or any other ns50 drive that is compatible, upload it and I will use dosflash 1.7 patched from dos prompt to try and save it, after erasing eeprom. Any other suggestions are welcome as well


#2

AAAnd…. it’s alive! used a win7 winpe disc x86 to run patched dosflash32 with an older pc, apparently this drive is NS40 hardware, bought in 2012! as version 1.00, while the LG flasher saw it as svc code NS50- WRONG! when I crossflashed to ns50 firmware of course it could not read anything. Yet I didn’t have any backup dumps!!, and flashing to an ASUS also same result- different hardware. I took the liberty of downloading an attached file from an old topic here on the forum, where a user had old drive with same issue, he uploaded a friends dump and was given a link to complete firmware with calibration data, to mirror his friends drive to his, what finally saved his drive. I did the same and used the winpe environment to dosflash32 erase the eeprom and flash the final firmware. Alas, his drive is not the same! but it worked! now I have instead of a dead wh14ns40, a very much functional BH16ns40. free writing speed upgrade. Thanks for all the guides and the main dosflash thread. here she is:


#3

update, this drive is sitting idle for several years, could be rusty, but it failed now on bd-r x6 verbatim media, without error code. Haven’t burned in years, still. This time I flashed a clean wh14ns40 original firmware 1.03-a0, so it is back to what it was, after a journey to hell. This time the media fails to burn again but with specific power calibration error, or session fixation error. Indeed it burns cd and probably dvd fine- didn’t try dvd. For now, I have a pioneer s09XLB on the way shipped. Also, got rid of iTunes gearASPIwdm driver, and cleaned up the cd filters in windows. now only cdrom.sys is present. But still it does not like this media. Could the calibration data I didn’t dump in the beginning got corrupt due to crossflash? I did flash the clean oem firmware now and drive seems to work fine, so either that or it’s rusty.


#4

Sounds like you lost the calibration data specific to this drive and replaced it with a different drive’s values.


#5

I have access to dosflash32 patched, and to unlocked flasher, and the devilclaw flasher. Can this data be resetted? BTW, when I flashed with dosflash32 it erased the eeprom, and flashed the foreign firmware with calibration data. in the next day I flashed with official lg clean firmware. what does that mean? it was named HLDS_JB7_BRAND_1.03-A0_NOBJ

EDIT: it is now burning fine and fast a dvd-r DL dual layer media without a hitch, So maybe it is calibrated, I am not the first of these drives to puke on cmc mag x6 bd-r after six years of service???