Adobe Flash and Internet Explorer compatability issue

i definately have Flash 9.0 latest version installed but when visiting some site with Flash sections they dont displays, instead i get a “you dont have flash, download the latest version now” box instead.

Saying that on some other sites it works, it seems pot luck if it works or not.

any idea’s?