Add-On PCI to IDE card won't DMA

Hi

Bought me a new add-on card today. No matter what I try, I just can’t get it to DMA when I install it and then connect a NEC 3500 dvdrw.
All I can get is Multiword DMA2 (ie. PIO4)
Can’t find any box or window to change this…

H/W, tested on $ntel 440LX, 815 and 865PE boxes.
OS= Win 2kpro_SP4. Also tried on a XP box without success.

Any help would be much appreciated. :wink:

Features :   

    * Bus Interface :- 32 bit PCI Bus
    * Chipset :- Silicon Image 0680 ATA Controller Chip 
    * Features :- 
          o Supports sofware Raid 0, 1 or 0 +1  ( optional, PCI-IDECMD0680R)
          o Supports IDE bus master DMA at 133Mbytes/sec PCI burst rate
          o Supports maximum PCI bus master data transfer rate of 66MB/sec. 
          o Two independent Ultra ATA channels with 128 Bytes buffer per channel 
          o Supports up to four IDE/ATA devices (coexists with other IDE and SCSI controllers) 
          o Fully backwards compatible with Ultra ATA/33, EIDE/Fast ATA-2 IDE & ATAPI devices 
          o Supports Ultra DMA2, 3, 4 ; Multi-Word DMA0, 1, 2 & PIO 2, 3, 4 driver modes 
          o Compliant to ATA/ATAPI-5 specification and PCI specification version 2.1. 
          o Enhanced data integrity of transferred data with CRC 
		(cyclical redundancy check) protection and verification 
          o Compatible with Microsoft IDE/ATA drives 
          o Supports Windows 95/98/ NT 4.0/2000/ME/XP,  DOS Operating System
             
    * Connectors : 
          o 2 X Ultra ATA 133 IDE connectors (ATA 133 Model)

@pinto2. With the Add on card it will not show up in normal UDMA as it goes under SCSI device and if it is an ATA 133 it will be in UDMA mode 6. A quick way to check is download SiSoft Sandra or PC wizard and it will tell you what mode it’s in under IDE devices. Also make sure the drivers are installed and reboot. Your Bios may also tell you what mode your attached IDE devices are in. :slight_smile:
Correction if you have a 133 ATA HD it will be UDMA6 and support what ever UDMA your Burner is. You would be better off attaching your HD to the add in controller and leaving your optical drives on normal IDE channels. Hope this helps.

Thanks for your prompt response crossg. :slight_smile:

Didn’t test with Sisoft Sandra yet, but Nero InfoTool should be able to detect “right” mode won’t it…?

Edit.

Hmm, yes maybe it will, but this move to PCI-IDE is part of an project posted… here.
On my other boxes I have all my ATAPI drives on IDE-connectors.

Note. Picture when on $ntel 440LX box, my home network server
.


Actually it doesn’t detect my HD a UDMA. Have a on board Promise controller and Nero Info tool does not say UDMA for my HD the only way I can tell is during boot, it says UDMA6 or Sisoft. This is my Info Tool:
nterface Information

Adapter 1

Description : Primary IDE Channel

Driver
Description : System32\DRIVERS\atapi.sys
Company : Microsoft Corporation
Version : 5.1.2600.1106 (xpsp1.020828-1920)
Description : IDE/ATAPI Port Driver

Attached Devices
Description : Master: _NEC DVD_RW ND-3520A
Type : CD-Rom Drive
DMA : On
Autorun : On
Description : Slave: BENQ DVD DD DW1620
Type : CD-Rom Drive
DMA : On
Autorun : On

Adapter 2

Description : Secondary IDE Channel

Driver
Description : System32\DRIVERS\atapi.sys
Company : Microsoft Corporation
Version : 5.1.2600.1106 (xpsp1.020828-1920)
Description : IDE/ATAPI Port Driver

Attached Devices
Description : Master: PLEXTOR DVDR PX-716A
Type : CD-Rom Drive
DMA : On
Autorun : On

Adapter 3

Description : WinXP Promise SATA378 ™ IDE Controller

Driver
Description : System32\DRIVERS\ulsata.sys
Company : Promise Technology, Inc.
Version : 1.00.0.26
Description : Promise Ultra/Sata Series Driver for WinXP

Attached Devices
Description : ID 5 (0): Maxtor 6Y120P0 YAR4
Type

I have done transfer rate test in Nero CD/DVD Speed and also with Nero 6.6.0.5, all I get is 15MB/s so the controller can’t be running more the PIO4 (Mw-DMA2) anyway…
But, I will d/l a free copy of Sandra and test with that. :wink:

off topic
Funny, we have same PromiseSATA controller and SATA 120GB HDD´s… My 865PE mobo is Asus 4P4800-SE…

I actually have my 2 ATA 133’s hooked up through my Promise S ATA Controller in IDE Mode as it gives me very fast transfer and burst rates IE: 49.9 mbs and 108 burst speed with these two HD. :slight_smile:

Posted this on a different thread & thought in the interest of helping others who come searching for information later I’d cross-post this here so it’d be easier to find for people in a similar situation…

Regarding the Sil0680a controller cards and NEC drives here is a true story that will make you go “Hmmmm…”

I have a Dell XPS system (very nice system except a little too pricy unless you get a 30% discount code like I did & throw some Klipsch 5.1 Ultras in the basket for 30% off of those, too with free shipping) and one of the features was it had one of the newer Intel chipset-based motherboards with just one PATA controller. Plenty for most people…unless you are a cough CD Freak cough that has 3 (Three!!!) PATA optical drives.

One of these drives is a NEC ND-3500AG drive & after trying everything in the world and every option available to me if I wanted my drives to be set up the way I wanted them I was going to need to hook my NEC drive to a Sil0680a card. As an aside, the Belkin RAID version of this card is the cheapest of all the brand name cards & you get a good warranty.

I had the same DMA problem listed in the thread referenced above. I tried everything. I flashed different versions of firmware of both the RAID & non-RAID variety to the controller card. I flashed different firmware revisions to the NEC drive. I tried different cables…I even tried an 80-pin cable out of desperation. Nothing worked.

After the frustration and depression passed I took stock of the situation. I was not getting the full potential out of this DVD burner, but what was I missing? Really the only thing I couldn’t do with things the way they were was burn at 16x. Well, to be honest, that’s no loss at all to me because near 100% of the media I buy is 8x rated media & I only burn at 8x so that consoled me a bit. I just let things ride the way they were. After all, no use banging your head to attain a feature you never use, yes?

Now here’s where things get interesting…fast forward five or six months & I am having a Burning Day. I’m consolidating stuff, sorting, burning, and deleting…doing some cleaning out of the old hard drives and making some archival backups. I’m surfing around the net while I do this…that’s how I do things. Catch up on my 'net reading & I’m able to be right there when the drives spits out the burned discs.

Anyway, I spy new drivers for my motherboards on-board Gigabit NIC (Broadcom BCM57xx-based in case you were curious). Being the upgrade whore that I am I stop what I’m doing, let the current disc finish burning, and upgrade the NIC driver. My old driver version was v7.xx and the new and improved version was v8.xx so I’m thinking maybe big changes were afoot & I rebooted the PC even though I didn’t have to just to make sure things would work properly.

I got back to my desktop & went back to burning DVDs and such. Now before DVD Decrypter would always default to 8x burning speed as that was the max my drive would support connected to the Sil0680a. Well, this time it defaulted to 16x! I checked all the usual places in Windows & with the Sil0680a drive utility thing and every place I looked now stated the drive was running at its max rated speed and data transfer rates. It has operated from that day to this day at maximum performance.

All that from just changing a NIC driver and rebooting. Weird. Like I said, makes you go “Hmmmm…”

P.S. Sorry this is such a long post, but I wanted to outline the course of events and stress that it truly was only a driver change for a seemingly unrelated piece of hardware that was responsible for the increase in functionality and performance.

Most IDE controllers do not work correctly with Optical drives. You should look over in IDE Controllers (The definitive Thread ) and see if you can find one that is compatible.

…commonly referred to as “the ghost in the machine”. Stuff like that happens many more times than one cares to know about - or would even believe :eek: When i asked Mike Tyson about it he told me “ith justh ludicrouth” …almost in a daffy-duck sorta way :wink:

There’s also something strange about the NEC burners and IDE controllers in general. On my new VIA board, the NEC is the only one of 4 that causes the HD activity light to come on and stay on any time the drive is reading or writing. We’ve seen lots of reports of the same thing on other controllers. I’ve also had the NEC cause certain programs to hang while detecting drives. :confused:

EyeForOne,
Definitely, I’ve seen the ghost in the machine on PCs in the past, but this was definitely the most odd.

rdgrimes,
VIA controllers are just weird anyway. Then install VIA’s IDE drivers and the weirdness expands exponentially.

Sorry for diging up this old thread of mine. :wink:

While helping out a member troubleshooting burn speed problems with same type of Sil-0680 PCI add-on card I discovered somthing interesting.
This card is not able to run in UDMA-2 mode with my NEC 3500 (post #1), BenQ 1620, BenQ1640 with any firmware. Multiworld DMA-2 is max, resulting in a burst rate of ~13MB/s.
But… my Lite-On 1693 has no problem to run at almost full possible UDMA speed with a burst rate of ~32MB/s+. :slight_smile:

I know there are still quite many Sil 0680 ATA controllers out there and especially BenQ owners have to be warned; don’t buy/use this IDE controller card with a BenQ 1620/1640 drive if you wanna burn above 8x speed.

  • pic1, transfer rate test BenQ 1640 BSLB firmware
  • pic2, transfer rate test BenQ 1640 BEFB (UDMA-4) firmware
  • pic3, burst rate test Lite-On 1693 KSOB (stock) firmware
    [Thanks to my son performing these tests]




pinto2, I ran into similar problems with using the SiI 0680A with certain manufacturers.

Works:

  1. LiteOn
  2. LG

Does NOT work:

  1. AOpen
  2. BenQ
  3. NEC

All my 3 LO & 1 LG drives were properly recognized at UDMA-4 & UDMA-2, respectively. However, when I tried to use the LG to create data disk with MCC004 or MCC03RG20 from the controller, it just crapped out. I’ve yet to try with LO.

BTW, this was using just a SiI 0680A NON-RAID controller card. I’ve also tried the ITE 8212F RAID and non-RAID controller cards, but they didn’t work properly even with nothing connected to the IDE ports. WXP Pro kept trying to set it up, but it always froze up the computer. Thus, they were returned before the SiI card came in.

Hi,

I experienced the same, when I tried to connect an optical drive to my onboard Promise PDC 20579:
Old LG 24x CD writer: not even capable to read properly, even CD playback fails
LG GSA 4163B: Reading okay, writing apparently okay, but the data written were corrupted
Liteon LTD 166s works fine, it is also possible to flash firmware.

It seems, that the Liteon drives are more tolerant than the others.

Michael

Thanks for your inputs KTL and mciahel. :slight_smile:

I don’t have a LG drive but I in no way doubt your findings. And for members with Lite-On DVDRW drives I can say; this add-on PCI card is a safe buy.

Attaching a burn at 16x on RiTEK-R03 @-R04 with Litey 1693 KSOB.
Finally a full speed burn with Sil-0680! :clap: Thanks to Jackie78 for bringing up this “problem” again.
.


The Promise normally has it’s own BIOS, you can easily go into it by pressing CTRL+F (or CTRL+G) and see if your drives are in PIO or DMA mode and which DMA mode…
Doesn’t work with ODD drives of course.

Those SIL controllers are cheap but great for ODD!

Hi,

and this what it looks like with a BenQ 1640, so be careful with this SIL 0680 controller if you are planning to use a BenQ drive. This drive works flawlessly on my VIA ONBOARD controller however (Asus A8V Deluxe).

cu,

Jackie

Hi,

That’s right.

you can easily go into it by pressing CTRL+F (or CTRL+G) and see if your drives are in PIO or DMA mode and which DMA mode…
Doesn’t work with ODD drives of course.
I didn’t try that, also the drive and its DMA-setting is displayed during the boot-up sequence. If I had a Liteon writer, I would try that on this controller;)

Michael

I just bought an Adaptec ASH-1233 which is Silicon Image 0680-based to power my new BenQ 1640 and 1655 drives. :frowning: Guess I’ll be running them off the onboard connectors…

[B]pinto2[/B]

I was able to get 18 MB/s with NEC on an IT8212F Controller. Check here -> http://club.cdfreaks.com/showpost.php?p=1370861&postcount=11

It´s still not enough. But better than the Silicon Image 0680A.

Regards.