AD5540 with 16x DVD-R Problem

Hello guys,

I have an Optiarc AD5540 in my dell xps laptop. The original firmware was ver 1.02c. With that firmware, I will get an error whenever I try to write to a DVD-R 16x media. Then I flashed the firmware with original version 2.01 downloaded from liggy’s site. Now I can burn DVD-R 16x media, but whenever I try to read it back, there will be a CRC error, meaning that the burned disc is useless.

I tried couple of times, and have the same result. Then I tried DVD+R 8x and it was fine. I’ve read that this drive support DVD-R 16x media, but what went wrong?

This is info I get from the disc…


Unique Disc Identifier : [DVD-R:MJC M005]

Disc & Book Type : [DVD-R] - [DVD-R]
Manufacturer Name : [MJC Pte. Ltd. Singapore ]
Manufacturer ID : [MJC M005]
Blank Disc Capacity : [2,298,496 Sectors = 4.71 GB (4.38 GiB)]

[ DVD Identifier V5.0.1 - http://DVD.Identifier.CDfreaks.com ]

Can anyone help, thanks for all your time…

Welcome to cdfreaks :slight_smile:
Your problem is probably caused by poor media quality.

I see, I will try other media, most probably SONY and will post the result here. Thanks.

This is a slimtype burner. If you can, stick to 8x rated dvd media.