AD-5630A necflash failed (mac os x snow leopard)

Hello,

I have an iMac (iMac7,1, Intel Core 2 Duo) with the following DVD: OPTIARC DVD RW AD-5630A. It’s running under Mac OS X 10.6.1

I tried a few days ago to make my dvd region free by using the “necflash” utility. As my driver was in the list of supported drivers (http://binflash.cdfreaks.com/#drivelist) , I decided to try this out. As indicated, I first scanned my adapters for valid devices:

./necflash -scan

The output given was the following one:

List of supported devices:

Device : A:
Vendor : OPTIARC
Model : DVD RW AD-5630A
Firmware : 1AHM

I then backed up my current firmware by issueing the following command:

./necflash -dump oldFirmware.bin A:

Downloaded the RPC1 firmware corresponding to my device (http://liggydee.cdfreaks.com/page/en/Optiarc-AD-5630A/)

I then then issued the following command:

./necflash -flash newFirmware.bin A:

The command ended without an error but since then, my DVD is not working at all anymore, it doesn’t recognize when I try to insert a disc or anything else.

Could anyone help me with this?

Best regards

What firmware exactly did you try to flash?

When you say that your drive does not detect any disc, can you still open and close the try? Another thing to check is if the drive LED is blinking. If that’s the case, the main firmware was not accepted for one reason or another. But this should usually not happen due to some checks while flashing.

Can you flash the old firmware again?

I’m trying to flash the following firmware: 1ahm_rpc1.bin

I’m on a iMac, so there aren’t any LED’s, and it’s like on Apple laptops, the disk is swallowed by the machine.

I tried to flash the old firmware but unfortunately it’s not working…

What should I do?

Does Binflash still recognize your drive when you use the -scan option and what firmware was on it before flashing? 1ahm without any patches? It’s a bit hard to tell what exactly went wrong without a drive LED which indicates if the drive is dead or just cannot run the main firmware. Is there an emergency eject for the disc that you could try?

that’s my output:

./necflash -scan
Binflash - NEC version - © by Liggy and Herrie
Visit http://binflash.cdfreaks.com

List of supported devices:

Device : A:
Vendor : OPTIARC
Model : DVD RW AD-5630A
Firmware : 1AHM

And unfortunately I don’t have an emergeny eject…

I don’t know what to do

Your drive still seems to have a valid main firmware. Have you already tried flashing back the firmware you originally dumped?

Yes, that’s the main problem, I tried but it didn’t work…

Then I have to admit that I’m completely clueless now :confused:

[QUOTE=vinzzzz;2441053]Yes, that’s the main problem, I tried but it didn’t work…[/QUOTE]

Did you get any error message(s) when you tried to reflash with the old firmware?