Acer TM4002 + QSI SDW-082 LX34 firm requested

vbimport

#1

Hi,

I’d like to revert my CD/DVD burner’s firmware to its original version.

It was at LX34, but upgrading it to LX43 didn’t solve my Audio CD burning problem.

So, I want back to LX34.

Thanks


#2

Hi

How do you check which version of the firmware you have?

Thx


#3

Is this maybe a Nutech clone or the other way around?
Haven’t seen a firmware for this QSI 082 ever…


#4

It is not possible to revert to an earlier Firmware.


#5

It is possible to go back and forth with LX43 and LX44


#6

More info would help here.


#7

It is not a general rule that you can’t go back to the previous firmware version. Sometimes you have to downgrade to even earlier version just to be able to upgrade to the version you want.
I used to have QSI-SDW-042 (it was replaced later with QSI-SDW-082 by service) and after a firmware upgrade form DX70 to newer from NU site I still had problem burning certain brands of quality DVD media. The problem was getting worse as newer media came to market replacing compatibile old ones. Before returnig this drive I wanted to check if the previous firmware DX70 would do better. The only way to do this was to downgrade the firmware below DX70 (as I remember it was DX35 and the drive description changed from 042 to 041) and then upgrade to DX70. After that everything was back to normal, yet still not satisfactory.

When I got my new sdw-082 and noticed that it’s also very media sensitive so I upgraded firmware to LX44 (the one from aopen site). I haven’t noticed much improvement so I tried flashing with different firmware and with LX43 from aopen site there waren’t any problems beside the notification, that the version is older than the current one. The other firmware including any form the NU site and the ones for phillips couldn’t be loaded as it returned error before flashing.


#8

Where can I get the DX35 firmware for the QSI SDW-042? I’ve done the same thing, I have upgraded to d363 and would like to go back. Does it matter what country your in when dealing with firmwares?


#9

That might have been DX31 (as is on NU site http://www.nu-europe.com/Support/Firmware/DX31.zip). You still need DX70 firmware. If you don’t have it just let me know and I’ll try to find it on my backup DVD’s.


#10

That would be greatly appreciated if you could also get me the DX70 firmware. I thank you in advance for the effort.


#11

I got the LX48 firmware from NU flashed in my QSI-082. Too eazy for asm geeks… :flower:
Not much testing yet, only that I can now burn succesfully DVDs that couldn’t with earlier QSI firmware versions (like Verbatims +R 8X), and no problems reading discs burned before the flashing or burned in other drives.
The site doesn’t allow attachkments of 1.24 MB, so if someone wants it or can host it, let me know.


#12

Can you mod the lx51 firmware as well?
It is available from http://www.amilo-forum.de/download.php?id=409 for the Philips SDVD8431 that as far as I know is the same drive.

If you can mod it I can host both of them. :wink:


#13

Done. Definitely the LX51 from Philips has improved media support very noticably.
I’d recommend the update for any SDW-082 for QSI, NU or Philips.


#14

Available at:
LX48
LX51
:bigsmile: :iagree: :clap:

A big thanks to Locati for the quick response :smiley:


#15

Thx for lx48, the other:

HTTP 404 - File not found


#16

Corrected…


#17

Thanks! :wink:


#18

I have this drive and it took forever to initialize and read some DVD’s that are very important to me. I updated the firmware from LX44 to LX51 and now the DVD’s are immediately recognized and play flawlessly. I was even considering replacing the drive but no more. So this firmware upgrade greatly improved my drive and saved me 80 bucks. Thanks again.


#19

Now the issue that rise is: the drive will keep the name after flashing LX51 bios from NU? Will it appear as QSI or will appear as NU if the previous firmware was QSI.


#20

It keeps the name…