Acer Aspire 5738z DvD drive & Bluetooth not working anymore

vbimport

#1

Well, hello everyone! I just installed Windows 7 on my Acer Aspire 5738Z and now i can´t see my DVD-RW Drive and my bluetooth is`nt working anymore.

Before Windows 7, there was Windows Vista home premium installed and everythink worked fine.

I just can´t find any drivers or a solution to my problem.

Could Someone help me further?


#2

Have you checked Acer for driver updates? You might need one for the bluetooth but not for your burner.


#3

I did installed all drivers from acer site, for windows 7, and at the bluethooh driver id says no bluetooth device detected. There are many drivers i didn´t know what was the good one, but i tried each of them, and from the vista compatiblity too. Nothing worked.
The volume buttons and some other buttons not intergrated in the keybord. So i tried vista drivers an and now they work.

Refered to the <dvd drive, i don´t know what i did, I installed a driver, but yesterday it did´nt appeared in my computer, and today when i started i did´n looked to see if its wokring, it must be something i did last night, or becouse i installed an Graphic driver from the windows update now, i don´t know for sure, but now the DVD drive appears normaly and it seems to be working.

Thx for the answer by the way!


#4

Give this a try: Link


#5

I did installed the software, and it showed me somethink with the bluetooth but nothink. It doesen´t work, and in the device manager it doesen´t shows any unknown devices.

I really don´t know whats the problem. Thx aldow!


#6

The device manager isn’t going to necessarily show an ‘unknown device’, you should look for the bluetooth device and follow the directions in that link.


#7

In device manager does it list the manufacturer of your Bluetooth? If you have Windows 7 64bit try this link for the driver: http://www.laptop-software.com/acer-software/acer-aspire-57385738g5738z5738zg-windows-7-64-bit-drivers/, they only have the Foxconn driver listed. Before you try installing a new driver, if your laptop has a switch to enable bluetooth, make sure it is on. Uninstall the bluetooth from Device Manager and reboot, if no driver is found or if it still doesn’t work, try the new driver.


#8

In searching I saw that it was Broadcom, but it couldn’t hurt trying another.


#9

[QUOTE=eric93se;2466170]In searching I saw that it was Broadcom, but it couldn’t hurt trying another.[/QUOTE]

Yes, it’s a bit confusing as to which device he actually has. I hope it’s listed in Device Manager.


#10

Well i did installed mobile device center… and set connection settings for bluetooth but nothing new in device manager.

I did looked in the User Guide of the Laptop, and the 3 buttons, network, bluetooth and backup manager are in the network, wirless area, so i installed a lot of wirless drivers from acer site, i don´t know which becouse there are many versions of drivers so i tried installing as many as i could.

But device manager still don´t shows any new activity.

Take a look. Thx.


#11

Is there a switch on the laptop to turn it on/off?

See if this thread helps: Link . Make sure you uninstall all old bluetooth software.


#12

Well the link doesen´t helps me allot. I tried installing a toshiba driver-software, and while the instalation there is a popup that´s installes the actual bluetooth device, and then comes another popup telling that i should plugin the bluetooth, so i press the switch [I](yes i have a separated switch that´s not part of the keyboard for turning it on/off, but i have and a shortcut too, on the keybord for the bluetooth for turning it on or off, however since windows 7 there shows just an icon when i´m pressing it)[/I], and than shows just the usual icon that bluetooth is´nt working. So i canceled the popup install and than the whole software-driver finished installing and i restarted my pc.

The difference is now that i have in Control Panel an bluetooth software and whenever i click on it, it popups the bluetooth install and another thing, don´t know what it´s about.

I don´t know what to do… for me and the DVD-Drive is still a mystery, how it got to be recognized by the PC.

I made a screenshot with the install shield, with the bluetooth icon that shows when i press the switch and that there is nothing new in the device manager after installing a part of toshiba bluetooth software-driver

I thankyou guys for trying understanding me and sorry becouse my english isn´t so good.

L.E.: I searched the manual for the name of my bluetoth device, it´s called Bluetooth® 2.0+EDR (Enhanced Data Rate)

ThX


#13

I am having the same issue. After receiving the laptop I formatted it and installed Win 7 64bit Ultimate, so I don’t know if the bluetooth was working previously or not since I didn’t test. You have done basically everything that I tried (installing every driver to everything on Acer’s site/backup DVD that I could find) and still no luck. I have had the same issue with the fingerprint reader. Neither show up in the device manager as either generic devices or unknown devices. I am beginning to wonder if Acer sells different machines with different built-in hardware. Perhaps mine doesn’t have a fingerprint reader or bluetooth built in. It would be easy if the fingerprint reader looked like every other fingerprint reader, but from what I understand the fingerprint reader is part of the touchpad in this model. Can anyone else clarify on that? If it’s not part of the touch pad then I think we could safely say that bluetooth and fingerprint reader are not necessarily in every 5738 that Acer shipped.


#14

Well i can remember that i did tested the bluetooth, whenever i pressed the switch the BT icon appeared and showed that’s it’s on, and the switch led from the BT was blinking, and when i turned it OFF, the icon showed it’s OFF and the LED was turned off to.

But i observed, that at the official Acer Site the drivers from the Vista partition and the drivers from W-7 aren’t the same. What i mean is that, i did installed from the vista place, 2 softwares that aren’t to be found at W-7, so i got to work my Volume keys, my Power Saving Switch, and now it shows me the icons, like the BT icon from the picture that shows that it’s OFF.

Strange somehow…


#15

Well, let me know if you get the BT working. I would like to get it working as well. I can’t even begin to troubleshoot if the OS doesn’t at least find the hardware as unknown.


#16

Yeah i will do so but still nothing new… i don´t know… i am thinking to install back Vista to see if it´s working… but … i don´t know i´m not ready becouse i set up my PC untill now and, i don´t want to go trough this again… But if somethink new comes up i will write here.


#17

Well, it turns out that in my case I don’t have BT or fingerprint reader. I spoke with the customer support person that shipped me the laptop and he confirmed that for my model I definitely don’t have them, so good luck with getting yours to work.


#18

Many Acers have a Bluethooth button but no Bluethooth hardware installed (I have 2 of them) my guess to keep the cost low, when few people use it.