Accessing Password protected 2nd local disk

Hi All

My friends computer recently died but the fool hadn’t backed anything up in ages so I offered to plug the (still working Hard Disk) into my PC and recover the files for him.

However he had set a password at startup to login and I am unable to access the files through my operating system.
He has given me the password he was using but I have no oportunity to enter it.

If u have any ideas let me know cheers


Hi and be welcome!

Did he use the NTFS file encryption? If so, I think you’re in trouble. The NTFS file encryption is related to a set of keys. In order to access your fs again, you need to have the set of keys. When your system disk is lost (format, harddrive crash). the keys disappaear along with it. And without keys, there’s no access.

For more detailed info, read this article:

AFAIK there is no tool that can recover keys from an ecrypted file system. From a technical point of view, it should be possible. So maybe there is a tool out there (couldn’t find one myself though).

You could try setting his drive as the primary master in your machine and your drive a slave or secondary master. Use his drive to boot into his OS, enter his password (His OS will have to install new drivers for your hardware), but after that and most likely a restart, you should be able to get the files you need. I have done this before and it worked for me. :iagree:

The logon passward has nothing to do with accessing the disk at this point.

Your problems has to do with permissions and ownership.

Since you did not specify Operating System or File System the assumption here is that you are using an NTFS based file system and hopefully as Dee-dhn pointed out, EFS was not employed. If my assumptions are incorrect then I apologize and you may disregard this post.

You must take ownership of the drive in order to access the files and folders on it. By default ownership is inherent to the original user.

First you need to disable Simple File Sharing if it is not already:

My Computer -> Tools -> Folder Options -> View tab -> Scroll to the bottom of the list of advanced settings and un-check Use Simple File Sharing (Recommended) -> Click OK.

Next go to the folder and right click on it and select Properties -> Security tab -> Advanced button -> Owner tab.
Select a new owner from the list and put a check in Replace owner on sub containers and objects -> Ok -> Ok

I could be way wrong here but I had to use Windows recovery console from my XP disc to recover from a system32/config corrupted or missing a couple of times and I seem to remember an option for removing Password protection in the DOS help menu from the XP Disc.?? Like I said could be wrong.

Hi Just want to thank Nemesys for advise, now I have access to my slave doc’s. Cheers

Yay. Access granted!

Nice post, Nemesys!

Thank you Nemesys !!! :bow: A virus got me and caused the HD to crash and I even found that upon accessing it the way you said to. Loosing all my pictures is what really had me pissed, everything is recovered and now backed up :o Thank you ! :bow:

I have been having the same problem and I found this post via google. i am using XP home SP2. When I try to follwo these instructions i find there is no option to disable simple file sharing, nor is there a replace owner option on secutiry tabs. I see this is an old post but i am hoping someone can help


with XP Home, the “take ownership” dialog is accessible if the computer is started in safe mode. Or install FaJo XP File Security Extension (XP FSE)
Alternatively you can boot up your system with a live Linux CD (Knoppix or Kanotix). These will give you at least reading access.